ipq40xx: add support for Mikrotik wAP R ac wap-r-ac
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 12 Nov 2022 12:13:46 +0000 (12:13 +0000)
committerAlexander Couzens <lynxis@fe80.eu>
Sat, 12 Nov 2022 18:30:42 +0000 (18:30 +0000)
The Mikrotik wAP R AC is an outdoor, dual band, dual radio (802.11ac) AP
with a miniPCIe slot for a LTE modem.
The wAP R AC is similar to the wAP AC but with the miniPCIe slot.

See https://mikrotik.com/product/wap_r_ac for more info.

Specifications:
- SoC: Qualcomm Atheros IPQ4018
- CPU: 4x ARM Cortex A7
- RAM: 128MB
- Storage: 16MB NOR flash
- Wireless:
   - Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, internal antenna
   - Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, internal antenna
- Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 2x 1000/100/10 ports
  one with 802.3af/at PoE in
- 1x Mini PCI-E port (USB2)

Installation:
Boot the initramfs image via TFTP, then flash the sysupgrade image using
sysupgrade. Details at https://openwrt.org/toh/mikrotik/common.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/preinit/05_set_iface_mac_ipq40xx.sh
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dts
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dtsi [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-r-ac.dts [new file with mode: 0644]
target/linux/ipq40xx/image/mikrotik.mk

index e682a0fb15700362e6972749e67d3287d12fbfd6..62507b81ea8c2ece75df12e6f1e6953aff6a435c 100644 (file)
@@ -64,7 +64,8 @@ ipq40xx_setup_interfaces()
        mobipromo,cm520-79f)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
-       mikrotik,wap-ac)
+       mikrotik,wap-ac|\
+       mikrotik,wap-r-ac)
                ucidef_set_interface_lan "sw-eth1 sw-eth2"
                ;;
        netgear,rbr50|\
index 9cdbaa3d4e7f6882b0e362eed6680667e4fbde0b..dee1021a1ecf503d31b34644b9ed658868f5b1ad 100644 (file)
@@ -118,7 +118,8 @@ case "$FIRMWARE" in
        mikrotik,hap-ac2 |\
        mikrotik,hap-ac3 |\
        mikrotik,hap-ac3-lte6-kit |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x0 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_0" 0x0 0x2f20 )
@@ -214,7 +215,8 @@ case "$FIRMWARE" in
        mikrotik,hap-ac3 |\
        mikrotik,hap-ac3-lte6-kit |\
        mikrotik,sxtsq-5-ac |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x8000 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_2" 0x0 0x2f20 )
@@ -250,7 +252,8 @@ case "$FIRMWARE" in
        mikrotik,hap-ac2 |\
        mikrotik,hap-ac3 |\
        mikrotik,hap-ac3-lte6-kit |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x2f20 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_0" 0x2f20 0x2f20 )
@@ -264,7 +267,8 @@ case "$FIRMWARE" in
        mikrotik,hap-ac3 |\
         mikrotik,hap-ac3-lte6-kit |\
        mikrotik,sxtsq-5-ac |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0xaf20 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_2" 0x2f20 0x2f20 )
index ddfef1ab2d42b8d858efff17e50625742f840e49..7b6bf932b1036227dd2e113c4583d727029507a7 100644 (file)
@@ -29,7 +29,8 @@ preinit_set_mac_address() {
                ip link set dev lan1 address $(macaddr_add "$base_mac" 1)
                ip link set dev eth0 address $(macaddr_setbit "$base_mac" 7)
                ;;
-       mikrotik,wap-ac)
+       mikrotik,wap-ac|\
+       mikrotik,wap-r-ac)
                base_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
                ip link set dev sw-eth1 address "$base_mac"
                ip link set dev sw-eth2 address $(macaddr_add "$base_mac" 1)
index 6b8f62d73586abff417b4a75be47102aee58e5f9..4bff00685968e91e470e0f1510337bac6ad1e71a 100644 (file)
@@ -177,7 +177,8 @@ platform_do_upgrade() {
        mikrotik,hap-ac3-lte6-kit|\
        mikrotik,lhgg-60ad|\
        mikrotik,sxtsq-5-ac|\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac|\
+       mikrotik,wap-r-ac)
                [ "$(rootfs_type)" = "tmpfs" ] && mtd erase firmware
                default_do_upgrade "$1"
                ;;
index ecbdfac15f81701a021301ec16f9af9aecf61be4..9af4ef257df53486662d4b9f09efb31c65fa9ed8 100644 (file)
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
 
-#include "qcom-ipq4019.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/soc/qcom,tcsr.h>
+#include "qcom-ipq4018-wap-ac.dtsi"
 
 / {
        model = "MikroTik wAP ac";
        compatible = "mikrotik,wap-ac";
 
-       memory {
-               device_type = "memory";
-               reg = <0x80000000 0x08000000>;
-       };
-
-       chosen {
-               stdout-path = "serial0:115200n8";
-       };
-
-       aliases {
-               led-boot = &led_user;
-               led-failsafe = &led_user;
-               led-running = &led_user;
-               led-upgrade = &led_user;
-       };
-
-       soc {
-               counter@4a1000 {
-                       compatible = "qcom,qca-gcnt";
-                       reg = <0x4a1000 0x4>;
-               };
-
-               tcsr@1949000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1949000 0x100>;
-                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
-               };
-
-               ess_tcsr@1953000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1953000 0x1000>;
-                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
-               };
-
-               tcsr@1957000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1957000 0x100>;
-                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               power {
-                       label = "blue:power";
-                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
-                       default-state = "keep";
-               };
-
-               led_user: user {
-                       label = "green:user";
-                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
-                       panic-indicator;
-               };
-       };
-};
-
-&prng {
-       status = "okay";
-};
-
-&tlmm {
-       serial_pins: serial_pinmux {
-               mux {
-                       pins = "gpio60", "gpio61";
-                       function = "blsp_uart0";
-                       bias-disable;
-               };
-       };
-
-       spi_0_pins: spi_0_pinmux {
-               pin {
-                       function = "blsp_spi0";
-                       pins = "gpio55", "gpio56", "gpio57";
-                       drive-strength = <2>;
-                       bias-disable;
-               };
-               pin_cs {
-                       function = "gpio";
-                       pins = "gpio54";
-                       drive-strength = <2>;
-                       bias-disable;
-                       output-high;
-               };
-       };
-};
-
-&blsp_dma {
-       status = "okay";
-};
-
-&blsp1_spi1 {
-       status = "okay";
-
-       pinctrl-0 = <&spi_0_pins>;
-       pinctrl-names = "default";
-       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
-
-       flash@0 {
-               reg = <0>;
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <40000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "Qualcomm";
-                               reg = <0x0 0x80000>;
-                               read-only;
-                       };
-
-                       partition@80000 {
-                               compatible = "mikrotik,routerboot-partitions";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               label = "RouterBoot";
-                               reg = <0x80000 0x80000>;
-
-                               hard_config {
-                                       read-only;
-                                       size = <0x2000>;
-                               };
-
-                               dtb_config {
-                                       read-only;
-                               };
-
-                               soft_config {
-                               };
-                       };
-
-                       partition@100000 {
-                               compatible = "mikrotik,minor";
-                               label = "firmware";
-                               reg = <0x100000 0xf00000>;
-                       };
-               };
-       };
-};
-
-&blsp1_uart1 {
-       status = "okay";
-
-       pinctrl-0 = <&serial_pins>;
-       pinctrl-names = "default";
-};
-
-&cryptobam {
-       status = "okay";
-};
-
-&crypto {
-       status = "okay";
-};
-
-&watchdog {
-       status = "okay";
-};
-
-&mdio {
-       status = "okay";
-};
-
-&gmac {
-       status = "okay";
-};
-
-&switch {
-       status = "okay";
-};
-
-&swport4 {
-       status = "okay";
-       label = "sw-eth2";
-};
-
-&swport5 {
-       status = "okay";
-       label = "sw-eth1";
-};
-
-&wifi0 {
-       status = "okay";
-
-       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
-};
-
-&wifi1 {
-       status = "okay";
-
-       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
 };
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dtsi
new file mode 100644 (file)
index 0000000..777f46e
--- /dev/null
@@ -0,0 +1,215 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       memory {
+               device_type = "memory";
+               reg = <0x80000000 0x08000000>;
+       };
+
+       chosen {
+               stdout-path = "serial0:115200n8";
+       };
+
+       aliases {
+               led-boot = &led_user;
+               led-failsafe = &led_user;
+               led-running = &led_user;
+               led-upgrade = &led_user;
+       };
+
+       soc {
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "blue:power";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+                       default-state = "keep";
+               };
+
+               led_user: user {
+                       label = "green:user";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+                       panic-indicator;
+               };
+       };
+};
+
+&prng {
+       status = "okay";
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <2>;
+                       bias-disable;
+               };
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               reg = <0>;
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "Qualcomm";
+                               reg = <0x0 0x80000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               compatible = "mikrotik,routerboot-partitions";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               label = "RouterBoot";
+                               reg = <0x80000 0x80000>;
+
+                               hard_config {
+                                       read-only;
+                                       size = <0x2000>;
+                               };
+
+                               dtb_config {
+                                       read-only;
+                               };
+
+                               soft_config {
+                               };
+                       };
+
+                       partition@100000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x100000 0xf00000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&crypto {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&mdio {
+       status = "okay";
+};
+
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport4 {
+       status = "okay";
+       label = "sw-eth2";
+};
+
+&swport5 {
+       status = "okay";
+       label = "sw-eth1";
+};
+
+&wifi0 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
+};
+
+&wifi1 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
+};
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-r-ac.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-r-ac.dts
new file mode 100644 (file)
index 0000000..14078e5
--- /dev/null
@@ -0,0 +1,53 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2022, Alexander Couzens <lynxis@fe80.eu> */
+
+#include "qcom-ipq4018-wap-ac.dtsi"
+
+/ {
+       model = "MikroTik wAP R ac";
+       compatible = "mikrotik,wap-r-ac";
+
+       soc {
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               usb3@8af8800 {
+                       status = "okay";
+
+                       dwc3@8a00000 {
+                               phys = <&usb3_hs_phy>;
+                               phy-names = "usb2-phy";
+                       };
+               };
+       };
+};
+
+&tlmm {
+       enable-usb-power {
+               gpio-hog;
+               gpios = <2 GPIO_ACTIVE_HIGH>;
+               output-high;
+               line-name = "enable USB power";
+       };
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb3 {
+       status = "okay";
+};
+
+&wifi0 {
+       qcom,ath10k-calibration-variant = "MikroTik-wAP-R-ac";
+};
+
+&wifi1 {
+       qcom,ath10k-calibration-variant = "MikroTik-wAP-R-ac";
+};
index 2b0e462efde4ad64bde79534b8eba2d7eee6d15b..1d72c5671bcb2c91375f42ccf179be0ecff1f84a 100644 (file)
@@ -78,3 +78,14 @@ define Device/mikrotik_wap-ac
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += mikrotik_wap-ac
+
+define Device/mikrotik_wap-r-ac
+       $(call Device/mikrotik_nor)
+       DEVICE_MODEL := wAP R ac
+       SOC := qcom-ipq4018
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
+               kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi \
+               kmod-usb-acm kmod-usb-net-rndis
+       DEVICE_DTS := qcom-ipq4018-wap-r-ac
+endef
+TARGET_DEVICES += mikrotik_wap-r-ac