ath79: Add support for TP-Link Archer C60 v2
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 5 May 2019 16:46:09 +0000 (18:46 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 17 Jul 2019 22:06:55 +0000 (00:06 +0200)
TP-Link Archer C60 v2 is a dual-band AC1350 router,
based on Qualcomm/Atheros QCA9561 + QCA9886.

Specification:

- 775/650/258 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR2)
- 8 MB of FLASH (SPI NOR)
- 3T3R 2.4 GHz
- 2T2R 5 GHz
- 5x 10/100 Mbps Ethernet
- 7x LED, 2x button
- UART header on PCB

Flash instruction (WebUI):
Download *-factory.bin image and upload it via the firmwary upgrade
function of the stock firmware WebUI.

Flash instruction (TFTP):
1. Set PC to fixed IP address 192.168.0.66
2. Download *-factory.bin image and rename it to tp_recovery.bin
3. Start a tftp server with the file tp_recovery.bin in its root
   directory
4. Turn off the router
5. Press and hold reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time the firmware should
   be transferred from the tftp server
8. Wait ~30 second to complete recovery

Flash instruction (under U-Boot, using UART):
tftp 0x81000000 ...-sysupgrade.bin
erase 0x9f030000 +$filesize
cp.b $fileaddr 0x9f030000 $filesize
reset

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9561_tplink_archer-c60-v2.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

index 981ff24e939434daa1a6b590e771b317e6d97993..16eb2d01e3a81b75dfb081d2dec2f6b8bb3c25c2 100755 (executable)
@@ -141,7 +141,8 @@ tplink,tl-wr842n-v3)
        ;;
 tplink,archer-c58-v1|\
 tplink,archer-c59-v1|\
-tplink,archer-c60-v1)
+tplink,archer-c60-v1|\
+tplink,archer-c60-v2)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
        ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
        ;;
index de77203152a5a277cef35c0bebd5c6cf42e87075..ed33ff5aad64d6f6e02adcdfe67a00c35fa3416e 100755 (executable)
@@ -217,7 +217,8 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
-       tplink,archer-c60-v1)
+       tplink,archer-c60-v1|\
+       tplink,archer-c60-v2)
                ucidef_set_interface_wan "eth1"
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan" "2:lan" "3:lan" "4:lan"
index 7fa85e90488af8f18a264fc40faa732cca1eb63c..d45003c8374414c10fc4824cc5f4e120fbbbac25 100644 (file)
@@ -209,6 +209,7 @@ case "$FIRMWARE" in
        tplink,archer-c58-v1|\
        tplink,archer-c59-v1|\
        tplink,archer-c60-v1|\
+       tplink,archer-c60-v2|\
        tplink,archer-c6-v2)
                ath10kcal_extract "art" 20480 12064
                ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary mac 8) -1)
diff --git a/target/linux/ath79/dts/qca9561_tplink_archer-c60-v2.dts b/target/linux/ath79/dts/qca9561_tplink_archer-c60-v2.dts
new file mode 100644 (file)
index 0000000..29f9167
--- /dev/null
@@ -0,0 +1,62 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9561_tplink_archer-c6x.dtsi"
+
+/ {
+       compatible = "tplink,archer-c60-v2", "qca,qca9561";
+       model = "TP-Link Archer C60 v2";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "factory-boot";
+                               reg = <0x000000 0x01fb00>;
+                               read-only;
+                       };
+
+                       mac: partition@1fb00 {
+                               label = "mac";
+                               reg = <0x01fb00 0x000500>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "u-boot";
+                               reg = <0x020000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x030000 0x7a0000>;
+                       };
+
+                       partition@7d0000 {
+                               label = "tplink";
+                               reg = <0x7d0000 0x020000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
index 51784650564f08cdde8e16209a45f7e2631cf1ce..ba9f06adf6d67dd0e1b1efd236ca8d758ade03af 100644 (file)
@@ -72,6 +72,18 @@ define Device/tplink_archer-c60-v1
 endef
 TARGET_DEVICES += tplink_archer-c60-v1
 
+define Device/tplink_archer-c60-v2
+  $(Device/tplink-safeloader-uimage)
+  ATH_SOC := qca9561
+  IMAGE_SIZE := 7808k
+  DEVICE_MODEL := Archer C60
+  DEVICE_VARIANT := v2
+  TPLINK_BOARD_ID := ARCHER-C60-V2
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  SUPPORTED_DEVICES += archer-c60-v2
+endef
+TARGET_DEVICES += tplink_archer-c60-v2
+
 define Device/tplink_archer-c6-v2
   $(Device/tplink-safeloader-uimage)
   ATH_SOC := qca9563