brcm2708: add kmod-sound-soc-googlevoicehat
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 6 Dec 2018 20:52:10 +0000 (22:52 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 18 Dec 2018 21:19:21 +0000 (23:19 +0200)
Add kernel module for Google Voice HAT support in kernel 4.14.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/brcm2708/modules.mk

index dbeaa21f26f27b7b27af413a35ce8eea9e4c7919..c460fba4b75c77b2a6e2c166547075d9f3620014 100644 (file)
@@ -382,6 +382,30 @@ endef
 
 $(eval $(call KernelPackage,sound-soc-fe-pi))
 
+
+define KernelPackage/sound-soc-googlevoicehat
+  TITLE:=Support for Google VoiceHAT Sound Card
+  KCONFIG:= \
+       CONFIG_SND_BCM2708_SOC_GOOGLEVOICEHAT_SOUNDCARD \
+       CONFIG_SND_SOC_VOICEHAT
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/bcm/snd-soc-googlevoicehat-codec.ko \
+       $(LINUX_DIR)/sound/soc/bcm/snd-soc-googlevoicehat-soundcard.ko
+  AUTOLOAD:=$(call AutoLoad,68,snd-soc-googlevoicehat-codec \
+       snd-soc-googlevoicehat-soundcard)
+  DEPENDS:= \
+       @LINUX_4_14 \
+       kmod-sound-soc-bcm2835-i2s
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-googlevoicehat/description
+  This package contains support for Google VoiceHAT Sound Card
+endef
+
+$(eval $(call KernelPackage,sound-soc-googlevoicehat))
+
+
 define KernelPackage/sound-soc-hifiberry-dac
   TITLE:=Support for HifiBerry DAC
   KCONFIG:= \