ramips: fix ralink_default_fw_size_16M
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 15 Jul 2019 12:55:02 +0000 (14:55 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 25 Jul 2019 12:31:01 +0000 (14:31 +0200)
In ramips, there are the following predefined values for IMAGE_SIZE
ralink_default_fw_size_4M    3866624   3776k   0x3B0000
ralink_default_fw_size_8M    8060928   7872k   0x7B0000
ralink_default_fw_size_16M  16121856  15744k   0xF60000
ralink_default_fw_size_32M  33226752  32448k  0x1FB0000

Out of those, the "16M" value is obviously odd, as it provides more
room for the remaining partitions than the tree others.
Of the devices in all subtargets, there are actually > 50 that have
a firmware partition with 0xFB0000 size, while only 5 (!) have
0xF60000. From the former, many are set to
ralink_default_fw_size_16M anyway, although it is wrong at the
present point.

Consequently, it makes sense to change ralink_default_fw_size_16M
to 0xFB0000, and to update IMAGE_SIZE for the 5 devices with
0xF60000.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt7621.mk
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/image/rt305x.mk

index 181c82587397e770019c390438601cbfc4e72d59..b1f0612941b4b027d7388ef2f73906085825907c 100644 (file)
@@ -150,7 +150,7 @@ endef
 
 ralink_default_fw_size_4M=3866624
 ralink_default_fw_size_8M=8060928
-ralink_default_fw_size_16M=16121856
+ralink_default_fw_size_16M=16449536
 ralink_default_fw_size_32M=33226752
 
 ifeq ($(SUBTARGET),rt288x)
index 36cc7d5204054d03a0c9e529a48322b7866df8b3..51030bc90b97542658cfe315057278daaf583755 100644 (file)
@@ -490,7 +490,7 @@ TARGET_DEVICES += kimax_u35wf
 
 define Device/kingston_mlw221
   MTK_SOC := mt7620n
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  IMAGE_SIZE := 15744k
   DEVICE_VENDOR := Kingston
   DEVICE_MODEL := MLW221
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
@@ -500,7 +500,7 @@ TARGET_DEVICES += kingston_mlw221
 
 define Device/kingston_mlwg2
   MTK_SOC := mt7620n
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  IMAGE_SIZE := 15744k
   DEVICE_VENDOR := Kingston
   DEVICE_MODEL := MLWG2
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
index f80a723c15024dc83710f438f99e4dc5ff2887ca..0902c4eedc84bfff5c9662e90e02e766a0cdde6d 100644 (file)
@@ -465,7 +465,7 @@ TARGET_DEVICES += netis_wf-2881
 
 define Device/phicomm_k2p
   MTK_SOC := mt7621
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  IMAGE_SIZE := 15744k
   DEVICE_VENDOR := Phicomm
   DEVICE_MODEL := K2P
   SUPPORTED_DEVICES += k2p
index fae9fb03cf09cf43270da563bc26348ef633d21a..4382bef7fc8623bac2fe6c268c095c6934c51365 100644 (file)
@@ -144,7 +144,7 @@ TARGET_DEVICES += mercury_mac1200r-v2
 define Device/netgear_r6120
   MTK_SOC := mt7628an
   BLOCKSIZE := 64k
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  IMAGE_SIZE := 15744k
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := R6120
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
index 2ba5e254e6eab029ed0346bc3ec5479e581ebbbc..073f505d49a0ac4c378e8dab03e26c5841819f1c 100644 (file)
@@ -579,7 +579,7 @@ TARGET_DEVICES += huawei_d105
 
 define Device/huawei_hg255d
   MTK_SOC := rt3052
-  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  IMAGE_SIZE := 15744k
   DEVICE_VENDOR := HuaWei
   DEVICE_MODEL := HG255D
   SUPPORTED_DEVICES += hg255d