ethtool: Update to 4.17
authorRobert Marko <robimarko@gmail.com>
Mon, 18 Jun 2018 15:50:47 +0000 (17:50 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 20 Jun 2018 13:36:02 +0000 (15:36 +0200)
Tested on 8devices Jalapeno(ipq40xx)
Introduces following changes
* Fix: In ethtool.8, remove superfluous and incorrect \
* Fix: fix uninitialized return value
* Fix: fix RING_VF assignment
* Fix: remove unused global variable
* Fix: several fixes in do_gregs()
* Fix: correctly free hkey when get_stringset() fails
* Fix: remove unreachable code
* Fix: fix stack clash in do_get_phy_tunable and do_set_phy_tunable
* Feature: Add register dump support for MICROCHIP LAN78xx

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/network/utils/ethtool/Makefile

index 0d85380ae448ef9a3c6af2e14fe004f702fb4580..565acd41d9ae68cbbd76058259b2bfdf7a495cc7 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ethtool
-PKG_VERSION:=4.16
+PKG_VERSION:=4.17
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
-PKG_HASH:=fe967a6722db2099fa63d847b6628e3e31cf9f53571a37503347dcc3e4015a03
+PKG_HASH:=c46b1eb417c78793dddb3247b89eb8f50f6e398e12ee4670b092b3570728c585
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING