ramips: add support for TOTOLINK A7000R
authorChuanhong Guo <gch981213@gmail.com>
Tue, 25 Jun 2019 15:32:20 +0000 (23:32 +0800)
committerPetr Štetiar <ynezz@true.cz>
Wed, 26 Jun 2019 05:41:54 +0000 (07:41 +0200)
Specifications:
- SoC: MT7621AT
- RAM: 128MB
- Flash: 16M SPI NOR
- Ethernet: 5x GE ports
- WiFi: 2.4G: MT7615N
        5G: MT7615N

Flash instruction:
Upload generated sysupgrade firmware through factory web interface.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/TOTOLINK-A7000R.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index ffd1689263307ca8fad00184d41a056c3b3df657..02ef30cadec58b8a7f4cc4c6c4a2e3f353eed2e0 100755 (executable)
@@ -125,6 +125,7 @@ ramips_setup_interfaces()
        sap-g3200u3|\
        sk-wb8|\
        telco-electronics,x1|\
+       totolink,a7000r|\
        totolink,lr1200|\
        unielec,u7621-06-256m-16m|\
        unielec,u7621-06-512m-64m|\
diff --git a/target/linux/ramips/dts/TOTOLINK-A7000R.dts b/target/linux/ramips/dts/TOTOLINK-A7000R.dts
new file mode 100644 (file)
index 0000000..4791862
--- /dev/null
@@ -0,0 +1,123 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "totolink,a7000r", "mediatek,mt7621-soc";
+       model = "TOTOLINK A7000R";
+
+       aliases {
+               led-boot = &led_sys;
+               led-failsafe = &led_sys;
+               led-running = &led_sys;
+               led-upgrade = &led_sys;
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x8000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_sys: sys {
+                       label = "a7000r:blue:sys";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0xfb0000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
index c1e445f84c07dcb69acc56b6a53243d5a641a877..dce24308b8c937aa70892d39b227d2754b89e3a9 100644 (file)
@@ -235,6 +235,15 @@ define Device/k2p
 endef
 TARGET_DEVICES += k2p
 
+define Device/totolink_a7000r
+  DTS := TOTOLINK-A7000R
+  IMAGE_SIZE := 16064k
+  UIMAGE_NAME := C8340R1C-9999
+  DEVICE_TITLE := TOTOLINK A7000R
+  DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += totolink_a7000r
+
 define Device/xiaomi_mir3p
   DTS := MIR3P
   BLOCKSIZE := 128k