busybox: add missing install dir
authorHans Dedecker <dedeckeh@gmail.com>
Fri, 1 Mar 2019 17:59:31 +0000 (18:59 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Mon, 11 Mar 2019 16:03:17 +0000 (17:03 +0100)
Add missing /usr/sbin install dir fixing :

install: cannot create regular file 'build_dir/target-x86_64_musl/busybox-1.30.1/.pkgdir/busybox/usr/sbin/ntpd-hotplug': No such file or directory

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/utils/busybox/Makefile

index 540a2ef3badd5997902a31046accb545663cefab..8ccf4358afdb900d0c9d2c7c0cd591d842d4c770 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.30.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -120,6 +120,7 @@ endef
 
 define Package/busybox/install
        $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron