gemini: add EOD marker to rootfs images
authorMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 09:15:06 +0000 (10:15 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 14:23:38 +0000 (15:23 +0100)
With 6409b159e8b8 ("gemini: switch to 4.14") the EOF marker were dropped
from the rootfs images. Without the marker the rootfs_data partition
can't be created and it isn't possible to permanently store any
configuration changes.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/gemini/image/Makefile

index 805c0372c190e644460a14ec87b9eeb76878a98d..78195cbbcc2edf9da1f0d13dd732d993af73b649 100644 (file)
@@ -130,7 +130,8 @@ TARGET_DEVICES += dlink_dns-313
 
 define Device/itian-raidsonic
        IMAGES := factory.bin
-       IMAGE/factory.bin := append-rootfs | pad-to 6144k | nas4220b-sq201-images $(1)
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
+               nas4220b-sq201-images $(1)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef