kernel: fix kmod-input-touchscreen-ads7846 deps
authorStijn Tintel <stijn@linux-ipv6.be>
Sun, 24 Feb 2019 22:49:39 +0000 (00:49 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Sun, 24 Feb 2019 23:07:20 +0000 (01:07 +0200)
On targets that don't have input support enabled in the kernel config,
building kmod-input-touchscreen-ads7846 fails due to a missing
dependency on kmod-input-core. Add the dependency to fix this.

Fixes: 77a54bbf13bf ("kernel: add kmod-input-touchscreen-ads7846")
Reported-by: Hannu Nyman <hannu.nyman@iki.fi>
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/input.mk

index 76b4f40bdd681458447474bf78a6caf0485da33a..99257b6725fc02de8cc1ada2b93a2ba6acd6ffca 100644 (file)
@@ -176,7 +176,7 @@ $(eval $(call KernelPackage,input-matrixkmap))
 define KernelPackage/input-touchscreen-ads7846
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens
-  DEPENDS:=+kmod-hwmon-core +kmod-spi-bitbang
+  DEPENDS:=+kmod-hwmon-core +kmod-input-core +kmod-spi-bitbang
   KCONFIG:= \
        CONFIG_INPUT_TOUCHSCREEN=y \
        CONFIG_TOUCHSCREEN_PROPERTIES=y \