mt76: update to the latest version
authorFelix Fietkau <nbd@nbd.name>
Fri, 27 Sep 2019 14:26:11 +0000 (16:26 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 29 Sep 2019 20:16:27 +0000 (22:16 +0200)
0167bfa7b277 mt76: make mt76_rx_convert static
1d2acd5639d7 mt76: mt76x0: remove redundant chandef copy
496c78e4f0d3 mt76: mt76x0: remove unneeded return value on set channel
67973788f47f mt76: mt7615: introduce mt7615_txwi_to_txp utility routine
c7f82146ef96 mt76: mt7615: add support to read temperature from mcu
e07407ac1279 mt7603: fix build with CONFIG_KERNEL_DYNAMIC_DEBUG=y
8739f87e9aeb mt76: mt7615: fix control frame rx in monitor mode
9c5df3cb6a6d mt76: remove aggr_work field from struct mt76_wcid
0efbc5d1c271 mt76: use cancel_delayed_work_sync in mt76_rx_aggr_shutdown
0308d75f28e4 mt76: remove empty flag in mt76_txq_schedule_list
a20c20bbe88d mt76: usb: add lockdep_assert_held in __mt76u_vendor_request
b140512e73bf mt76: mt76x0e: make array mt76x0_chan_map static const, makes object smaller
63e815254075 mt76: mt7615: enable SCS by default
f3792b550fdb mt76: mt76x02: move mac_reset_counter in mt76x02_lib module
0355b7ae2b05 mt76: mt76x2: move mt76x02_mac_reset_counters in mt76x02_mac_start
c39488772d6b mt76: mt76x0u: reset counter starting the device
0b01aceeeff8 mt76: mt76x02u: move mt76x02u_mac_start in mt76x02-usb module
fbc59e64396e mt76: move queue debugfs entry to driver specific code
1118b5ea76be mt76: mt7615: add queue entry in debugfs
23e8aed3ac99 mt76: move aggr_stats array in mt76_dev
696c0fc5516a mt76: mt7615: collect aggregation stats
081926aa7b27 mt76: mt7603: collect aggregation stats
ea3ab68c7589 mt76: mt7615: fix mt7615 firmware path definitions
1ddcadb72e96 mt76: mt7603: remove q_rx field from struct mt7603_dev
202776352b0a mt76: report rx a-mpdu subframe status
b0429879eab2 mt76: rename mt76_driver_ops txwi_flags to drv_flags and include tx aligned4
a1d6891501a1 mt76: store current channel survey_state in struct mt76_dev
f34b1ae42cd0 mt76: track rx airtime for airtime fairness and survey
ee310307ad42 mt76: mt7603: track tx airtime for airtime fairness and survey
fdf0163fd101 mt76: mt7603: switch to a different counter for survey busy time
de118bb403d1 mt76: unify channel survey update code
3429cc7d36da mt76: mt76x02: move MT_CH_TIME_CFG init to mt76x02_mac_cc_reset
0e5050ee799c mt76: mt76x02: track approximate tx airtime for airtime fairness and survey
028071d9594c mt76: mt7615: report tx_time, bss_rx and busy time to mac80211
d91f7c1bcdf7 mt76: mt7615: fix survey channel busy time
2579122ba209 mt76: mt7615: introduce mt7615_mac_wtbl_update routine
81f2be0c459f mt76: mt7615: track tx/rx airtime for airtime fairness
e7199f944793 mt76: enable airtime fairness
8f22de061129 mt76: do not use devm API for led classdev
6f7d0f503d10 mt76: fix use-after-free bug in airtime fairness code

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index 49687a6a3c1c044eb42343eb57b2a6875240457e..4b2d3184a89767413a927f0067d2c5852df00156 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-08-22
-PKG_SOURCE_VERSION:=2a0edbb4473b71dfaa4756f7189abf6cb7f7be8b
-PKG_MIRROR_HASH:=a37975c179b929716c40d19fdcd5b131386d7f497eb8cd5d848be74e76d50d21
+PKG_SOURCE_DATE:=2019-09-29
+PKG_SOURCE_VERSION:=6f7d0f503d1013f0909fe52075da5d5d500ddca4
+PKG_MIRROR_HASH:=08da91583d1479f65d3d9921ee5de129c6ec0235d584eb784960a994cd7cbe0f
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1
@@ -247,12 +247,12 @@ define KernelPackage/mt7603/install
 endef
 
 define KernelPackage/mt7615e/install
-       $(INSTALL_DIR) $(1)/lib/firmware
+       $(INSTALL_DIR) $(1)/lib/firmware/mediatek
        cp \
                $(PKG_BUILD_DIR)/firmware/mt7615_cr4.bin \
                $(PKG_BUILD_DIR)/firmware/mt7615_n9.bin \
                $(PKG_BUILD_DIR)/firmware/mt7615_rom_patch.bin \
-               $(1)/lib/firmware
+               $(1)/lib/firmware/mediatek
 endef
 
 $(eval $(call KernelPackage,mt76-core))