ar71xx: lzma-loader: set page size to 4KB
authorMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 5 Jun 2018 22:27:42 +0000 (00:27 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 6 Jun 2018 20:25:52 +0000 (22:25 +0200)
The text section in the ELF loader is aligned to the maximum page size,
which defaults to 64KB. Reduce it to the actual page size to avoid wasting
flash space for this alignment.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
target/linux/ar71xx/image/lzma-loader/src/Makefile

index c54f64a550b6fab66b87589e335d646b5f91ba19..7773f027a24975bb7204b1dec141e3bd39092874 100644 (file)
@@ -97,7 +97,7 @@ loader2.o: loader.bin
        $(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
 
 loader.elf: loader2.o
-       $(LD) -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
+       $(LD) -z max-page-size=0x1000 -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
 
 mrproper: clean