ath10k-ct: Update to 2019-06-13
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 13 Jun 2019 18:06:25 +0000 (19:06 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 13 Jun 2019 18:35:19 +0000 (19:35 +0100)
Changes:

ath10k:  Improve PMF/MPF mgt frame check

And add a driver for 5.2 (beta, not even tested yet) kernel.

Refresh patches.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/081-ath10k-calibration-variant.patch
package/kernel/ath10k-ct/patches/161-ath10k-add-support-for-configuring-management-packet.patch
package/kernel/ath10k-ct/patches/162-ath10k-fix-possible-out-of-bound-access-of-ath10k_ra.patch
package/kernel/ath10k-ct/patches/163-ath10k-fix-incorrect-multicast-broadcast-rate-settin.patch
package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
package/kernel/ath10k-ct/patches/201-ath10k-4.16_add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/ath10k-ct/patches/202-ath10k-4.16-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/203-ath10k-Limit-available-channels-via-DT-ieee80211-fre.patch

index 8ade145983351fa33aa1e22861ccbe54c38912c6..8dc28b44e799f9f65cefd867e074275990da03f4 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-05-08
-PKG_SOURCE_VERSION:=f98b6dc4d27ea2d79a1577285d1d5cb0641b3eb4
-PKG_MIRROR_HASH:=ca2f0e9da25fc7140d26ddeeb8e929e172755aa0e41e4e92e5b87bb972b8ed41
+PKG_SOURCE_DATE:=2019-06-13
+PKG_SOURCE_VERSION:=a045b1ce61fe0908468c019e17a3848f7842c927
+PKG_MIRROR_HASH:=d5e37e129f1c55517461fec491804c52dca27bb3cae96f077ccbe6e1b6a5f834
 
 # Build the 4.19 ath10k-ct driver version.  Other options are "-4.16", or
 # leave un-defined for 4.7 kernel.  Probably this should match as closely as
index 2b4273076b310cb9c45d8a6227b0898524febfe4..c5a477559862db9e159e7a86fbd764f558f5b71f 100644 (file)
@@ -98,7 +98,7 @@ Origin: upstream, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
        scnprintf(name, name_len,
                  "bus=%s,vendor=%04x,device=%04x,subsystem-vendor=%04x,subsystem-device=%04x%s",
                  ath10k_bus_str(ar->hif.bus),
-@@ -3014,7 +3036,11 @@ static int ath10k_core_probe_fw(struct a
+@@ -3028,7 +3050,11 @@ static int ath10k_core_probe_fw(struct a
  
        ret = ath10k_core_check_smbios(ar);
        if (ret)
index 10b1d384bde0e16ea3d3d394688f30a14e4606c5..d62a1cfcf5fc78706908aa0a20eb222f44da7a82 100644 (file)
@@ -43,7 +43,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
  static int ath10k_mac_get_max_vht_mcs_map(u16 mcs_map, int nss)
  {
        switch ((mcs_map >> (2 * nss)) & 0x3) {
-@@ -6333,9 +6349,10 @@ static void ath10k_bss_info_changed(stru
+@@ -6388,9 +6404,10 @@ static void ath10k_bss_info_changed(stru
        struct cfg80211_chan_def def;
        u32 vdev_param, pdev_param, slottime, preamble;
        u16 bitrate, hw_value;
@@ -56,7 +56,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
  
        mutex_lock(&ar->conf_mutex);
  
-@@ -6541,6 +6558,30 @@ static void ath10k_bss_info_changed(stru
+@@ -6596,6 +6613,30 @@ static void ath10k_bss_info_changed(stru
                                    arvif->vdev_id,  ret);
        }
  
index f46bf4dc83a2edc4c69dfef3f9b50657b365f24f..ab360b7261458c8de9a634b703ce5d9ef68de7c3 100644 (file)
@@ -26,7 +26,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
                if (ath10k_rates[i].bitrate == bitrate)
                        return hw_value_prefix | ath10k_rates[i].hw_value;
        }
-@@ -6564,22 +6564,22 @@ static void ath10k_bss_info_changed(stru
+@@ -6619,22 +6619,22 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 42d59e8e7276272b74d8627d7532508f9c3feac0..2b550e76df7eb0e1cfd80f25ffb5b9561e7679ac 100644 (file)
@@ -17,7 +17,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
 
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -6349,8 +6349,8 @@ static void ath10k_bss_info_changed(stru
+@@ -6404,8 +6404,8 @@ static void ath10k_bss_info_changed(stru
        struct cfg80211_chan_def def;
        u32 vdev_param, pdev_param, slottime, preamble;
        u16 bitrate, hw_value;
@@ -28,7 +28,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
        enum nl80211_band band;
        const struct ieee80211_supported_band *sband;
  
-@@ -6523,7 +6523,11 @@ static void ath10k_bss_info_changed(stru
+@@ -6578,7 +6578,11 @@ static void ath10k_bss_info_changed(stru
        if (changed & BSS_CHANGED_MCAST_RATE &&
            !WARN_ON(ath10k_mac_vif_chan(arvif->vif, &def))) {
                band = def.chan->band;
index ec8248f67b1ccdcb93d9c35448890bbc26fe5623..f15411853784e911261ecb4229b3eb5dfa023046 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
 
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -6545,6 +6545,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6600,6 +6600,7 @@ static void ath10k_bss_info_changed(stru
                           "mac vdev %d mcast_rate %x\n",
                           arvif->vdev_id, rate);
  
@@ -19,7 +19,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->mcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6553,6 +6554,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6608,6 +6609,7 @@ static void ath10k_bss_info_changed(stru
                                    "failed to set mcast rate on vdev %i: %d\n",
                                    arvif->vdev_id,  ret);
  
@@ -27,7 +27,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->bcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6579,6 +6581,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6634,6 +6636,7 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 617505def9c79996085f63c646a96e75c37fba26..f7eb34677baf0d3b2c009e062fc7eda85c65693a 100644 (file)
@@ -161,7 +161,7 @@ v13:
                .patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
-@@ -3084,6 +3090,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -3098,6 +3104,10 @@ int ath10k_core_start(struct ath10k *ar,
                        ath10k_wmi_check_apply_board_power_ctl_table(ar);
        }
  
@@ -172,7 +172,7 @@ v13:
        return 0;
  
  err_hif_stop:
-@@ -3330,9 +3340,18 @@ static void ath10k_core_register_work(st
+@@ -3344,9 +3354,18 @@ static void ath10k_core_register_work(st
                goto err_spectral_destroy;
        }
  
@@ -191,7 +191,7 @@ v13:
  err_spectral_destroy:
        ath10k_spectral_destroy(ar);
  err_debug_destroy:
-@@ -3390,6 +3409,8 @@ void ath10k_core_unregister(struct ath10
+@@ -3404,6 +3423,8 @@ void ath10k_core_unregister(struct ath10
        if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
                return;
  
@@ -553,7 +553,7 @@ v13:
  int ath10k_wmi_attach(struct ath10k *ar)
 --- a/ath10k-4.16/wmi.h
 +++ b/ath10k-4.16/wmi.h
-@@ -3013,6 +3013,41 @@ enum wmi_10_4_feature_mask {
+@@ -3016,6 +3016,41 @@ enum wmi_10_4_feature_mask {
  
  };
  
@@ -674,7 +674,7 @@ v13:
                .patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
-@@ -3147,6 +3153,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -3161,6 +3167,10 @@ int ath10k_core_start(struct ath10k *ar,
                        ath10k_wmi_check_apply_board_power_ctl_table(ar);
        }
  
@@ -685,7 +685,7 @@ v13:
        return 0;
  
  err_hif_stop:
-@@ -3401,9 +3411,18 @@ static void ath10k_core_register_work(st
+@@ -3415,9 +3425,18 @@ static void ath10k_core_register_work(st
                goto err_spectral_destroy;
        }
  
@@ -704,7 +704,7 @@ v13:
  err_spectral_destroy:
        ath10k_spectral_destroy(ar);
  err_debug_destroy:
-@@ -3461,6 +3480,8 @@ void ath10k_core_unregister(struct ath10
+@@ -3475,6 +3494,8 @@ void ath10k_core_unregister(struct ath10
        if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
                return;
  
@@ -1075,7 +1075,7 @@ v13:
  int ath10k_wmi_attach(struct ath10k *ar)
 --- a/ath10k-4.19/wmi.h
 +++ b/ath10k-4.19/wmi.h
-@@ -3041,6 +3041,41 @@ enum wmi_10_4_feature_mask {
+@@ -3044,6 +3044,41 @@ enum wmi_10_4_feature_mask {
  
  };
  
index 394e06990c8331e4858a2a2447802107c40945be..7784bf5251d67ac9653238b0bf1f0449a1b4805e 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-4.16/mac.c
 +++ b/ath10k-4.16/mac.c
-@@ -9739,7 +9739,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9794,7 +9794,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
  
  #ifdef CPTCFG_MAC80211_LEDS
@@ -79,7 +79,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -9908,7 +9908,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9963,7 +9963,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
  
  #ifdef CPTCFG_MAC80211_LEDS
index 45619c91692d101428af8941a432428a655f0a15..7a5b4fd21f7466c393cf7c86a6bbdb8fc19ef755 100644 (file)
@@ -29,7 +29,7 @@ Forwarded: https://patchwork.kernel.org/patch/10549245/
  #include <net/mac80211.h>
  #include <linux/etherdevice.h>
  #include <linux/acpi.h>
-@@ -9632,6 +9633,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9687,6 +9688,7 @@ int ath10k_mac_register(struct ath10k *a
                ar->hw->wiphy->bands[NL80211_BAND_5GHZ] = band;
        }