utils/spidev_test: side-step build-system woes
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 7 Jul 2022 12:10:17 +0000 (14:10 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 15 Jul 2022 13:21:44 +0000 (15:21 +0200)
The spidev_test is build in phase2 even though it should be disabled.
My best guess is that we hit the same issue that I had with nu801.
The build-system thinks it's a tool that is necessary for
building the kernel.

In this case, the same fix (adding a dependency on the presence of
the module) could work in this case as well?

Fixes: bdaaf66e28bd ("utils/spidev_test: build package directly from Linux")
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/utils/spidev_test/Makefile

index 0f288ad01060fe8b5ccb498cd84dbea2bc1ec6f2..a756b3633b2c37fa6ba72e9ced099b0ccf04114b 100644 (file)
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/spidev-test
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+kmod-spi-dev @!IN_SDK
+  DEPENDS:=+PACKAGE_kmod-spi-dev:kmod-spi-dev @!IN_SDK
   TITLE:=SPI testing utility
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org