ubox: fix init script validation of log_ip option
authorJo-Philipp Wich <jo@mein.io>
Fri, 28 May 2021 13:23:14 +0000 (15:23 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 28 May 2021 13:23:14 +0000 (15:23 +0200)
The underlying logread process uses usock() to handle remote connections
which is able to handle both hostnames and IP addresses.

Ref: https://github.com/openwrt/luci/issues/5077
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/system/ubox/Makefile
package/system/ubox/files/log.init

index f32e93ca8079fb6dac35960947033481d577f049..9ba4abdd581a1d54918d2574f8b1020a5662aed7 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubox
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubox.git
index 250f805b440619a5d799643acb29876af77fc624..c4802d4199242c7931ebfa79c51d41f563062b9d 100644 (file)
@@ -15,7 +15,7 @@ validate_log_section()
                'log_file:string' \
                'log_size:uinteger' \
                'log_hostname:string' \
-               'log_ip:ipaddr' \
+               'log_ip:host' \
                'log_remote:bool:1' \
                'log_port:port:514' \
                'log_proto:or("tcp", "udp"):udp' \