tools: mold: update to 2.1.0
authorAndre Heider <a.heider@gmail.com>
Sun, 30 Jul 2023 11:24:25 +0000 (13:24 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 14 Aug 2023 18:14:49 +0000 (20:14 +0200)
v2.0.0:
- transition from AGPL to MIT
- Previously, mold could not produce an object file with more than 65520
  sections using the --relocatable option. Now the bug has been fixed.
- mold now interprets -undefined as a synonym for --undefined instead of
  -u ndefined. This seems inconsistent, as -ufoo is generally treated as
  -u foo (which is an alias for --undefined foo), but this is the behavior
  of the GNU linkers and LLVM lld, so we prioritize compatibility over
  consistency.
- -nopie is now handled as a synonym for --no-pie.
- [RISC-V] R_RISCV_SET_ULEB128 and R_RISCV_SUB_ULEB128 relocation types are
  now supported (4bffe261ac5fe7)
- [PPC64] R_PPC64_REL32 relocation type is now supported. (ebd780e)

v2.1.0:

- Loongson's LoongArch CPU has been supported. (03b1a1c)
- -z nosectionheader has been added to eliminate section headers from the
  output file. (084ca55)
- Previously, linking with the -z pack-relative-relocs option produces an
  executable that glibc 2.38 refuses to run with DT_RELR without
  GLIBC_ABI_DT_RELR dependency error. Now, mold produces binaries compatible
  with glibc 2.38. (f467ad1)
- [ARM64] R_AARCH64_ADR_PREL_PG_HI21_NC relocation type has been supported.
  (17a5c3e)
- [ARM64] R_AARCH64_MOVW_UABS_G3 relocation type has now been handled as a
  PLT-generating relocation to fix an issue when main is not defined in the
  main executable but rather in a .so file. (e764557)
- [RISC-V] We now merge input .riscv.attributes contents. Previously, we
  just concatenated them. (aa64491)

Signed-off-by: Andre Heider <a.heider@gmail.com>
tools/mold/Makefile

index e8fcecbfed69411d6f0e4b0b471957072c194011..b266cea77dc33fa8dd30d6835b03fe93cbcae21e 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mold
-PKG_VERSION:=1.11.0
+PKG_VERSION:=2.1.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL_FILE:=v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/rui314/mold/archive/refs/tags
-PKG_HASH:=99318eced81b09a77e4c657011076cc8ec3d4b6867bd324b8677974545bc4d6f
+PKG_HASH:=a32bec1282671b18ea4691855aed925ea2f348dfef89cb7689cd81273ea0c5df
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk