ath79: mikrotik: bump compat version for yafut images
authorThibaut VARÈNE <hacks@slashdirt.org>
Fri, 5 May 2023 12:54:03 +0000 (14:54 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 15 May 2023 13:35:52 +0000 (15:35 +0200)
Following 5264296, Mirotik NAND devices now use yafut to flash the
kernel on devices. This method is incompatible with the old-style
"kernel2minor" flash mechanism.

Even though NAND images were disabled in default build since 21.02, a
user flashing a new-style image onto an old-style image would result in
in a soft-brick[1]. In order to prevent such accidental mishap,
especially as these device images will be reenabled in the upcoming
release, bump the compat version.

After the new image is flashed, the compat version can be updated:

    uci set system.@system[0].compat_version='1.1'
    uci commit

[1] https://github.com/openwrt/openwrt/pull/12225#issuecomment-1517529262

Cc: Michał Kępień <openwrt@kempniu.pl>
Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Reviewed-by: Robert Marko <robimarko@gmail.com>
target/linux/ath79/image/common-mikrotik.mk

index ce349b60b1d7f9664ab1aeee818b7db0c269995b..b37c8b7197067cf18930e7b53f5270d768b156b9 100644 (file)
@@ -18,4 +18,8 @@ endef
 define Device/mikrotik_nand
   $(Device/mikrotik)
   IMAGE/sysupgrade.bin = append-kernel | sysupgrade-tar | append-metadata
+  DEVICE_COMPAT_MESSAGE := \
+       NAND images switched to yafut. If running older image, reinstall from initramfs.
+  DEVICE_COMPAT_VERSION := 1.1
+
 endef