prereq: make existing binary check work for sdk as well
authorJonas Gorski <jonas.gorski@gmail.com>
Wed, 16 Aug 2023 09:22:30 +0000 (11:22 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Sat, 26 Aug 2023 12:00:36 +0000 (14:00 +0200)
To avoid replacing host built binaries with symlinks again, a check for
an appropriate stamp was added in 729909c07f ("prereq-build: do not
replace binaries with symlinks"). Unfortunately the stamp directory does
not exist in the SDK, so the fix was ineffective there.

This caused the packages builders to e.g. use the host tar again, which
in turn made the tarballs created different since it may lack
reproducibility fixes, or implement these differently, causing spurious
hash failures on source repository based packages.

Fix this by dropping the stamp dir check, and just check that the file
is usable.

Fixes: 729909c07f ("prereq-build: do not replace binaries with symlinks")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
include/prereq.mk

index 546f36b8e3e8a54628870bf2c90602580b9718c0..a4a07c223fa2653ec17ff80bf10a3fd1954c893a 100644 (file)
@@ -111,7 +111,6 @@ define SetupHostCommand
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
                                        "-"*) \
-                                               find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
                                        *" -> /"*) \