tools/ccache: update to 4.9.1
authorNick Hainke <vincent@systemli.org>
Mon, 12 Feb 2024 00:14:11 +0000 (01:14 +0100)
committerNick Hainke <vincent@systemli.org>
Mon, 12 Feb 2024 08:51:03 +0000 (09:51 +0100)
Release Notes:
https://ccache.dev/releasenotes.html#_ccache_4_9_1

Manually refresh patch:
- 100-honour-copts.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/ccache/Makefile
tools/ccache/patches/100-honour-copts.patch

index ace6bc3f42e0c77120c0e1e4c0007eefc1675fcd..5720dabf6ed6632f482d8d38ac853b6b3a56d99b 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=4.9
+PKG_VERSION:=4.9.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=1ebc72324e3ab52af0b562bf54189d108e85eef6478d6304a345a3c2dc4018e0
+PKG_HASH:=4c03bc840699127d16c3f0e6112e3f40ce6a230d5873daa78c60a59c7ef59d25
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk
index becfc9fe29a14cee32dcb517ae3f8a847261ed7c..8f1c426501880621340ca01fea7945b7fc8b845a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/ccache.cpp
 +++ b/src/ccache.cpp
-@@ -1843,6 +1843,7 @@ get_manifest_key(Context& ctx, Hash& has
+@@ -1841,6 +1841,7 @@ get_manifest_key(Context& ctx, Hash& has
      "OBJCPLUS_INCLUDE_PATH",        // Clang
      "CLANG_CONFIG_FILE_SYSTEM_DIR", // Clang
      "CLANG_CONFIG_FILE_USER_DIR",   // Clang