toolchain: remove references to $(LIBC)/utils subtarget
authorMichael Pratt <mcpratt@pm.me>
Tue, 21 Feb 2023 19:58:20 +0000 (14:58 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 25 Feb 2023 12:45:18 +0000 (13:45 +0100)
The utils subtarget was used for uClibc and eglibc
which are both obsolete and replaced in Openwrt by mainline
musl and glibc, which do not have a utils Makefile target.

Ref: 5d19a38d8 ("toolchain: sync eglibc headers/build split with uclibc changes")
Fixes: 63fb17520 ("toolchain: remove uClibc-ng")
Suggested-by: Andre Heider <a.heider@gmail.com>
Signed-off-by: Michael Pratt <mcpratt@pm.me>
toolchain/Makefile

index 60e35072507f1ee1101a8fd646034111fd94ba01..c0046293c9244ac4f4c0d6e8cbfff713934489b7 100644 (file)
@@ -21,8 +21,6 @@
 #    build & install the final libc
 # 7) toolchain/gcc/final/compile
 #    build & install the final gcc
-# 8) toolchain/libc/utils/compile
-#    build & install libc utilities
 #
 # For musl, steps 2 and 4 are skipped, and step 3 is done after 5
 
@@ -46,7 +44,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile $(curdir)/kernel-headers/compile
   $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
-  $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
 endif
 
 ifndef DUMP_TARGET_DB