ramips: fix build error on Airlink AR670W
authorShiji Yang <yangshiji66@qq.com>
Fri, 19 May 2023 06:05:01 +0000 (14:05 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 19 May 2023 21:33:49 +0000 (23:33 +0200)
The 'KERNEL' is not referenced by other objects, so double '$$' will
cause shell unable to parse the variable 'BLOCKSIZE':
  dd ... bs=$(BLOCKSIZE) conv=sync
  bash: line 1: BLOCKSIZE: command not found

Fixes: 09a0efbe83(ramips: set default BLOCKSIZE to 64k for nor flash devices)
Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/image/rt288x.mk

index 3d2d0c7ae02d8da4d7d125aae0f0f2a42b64d8a2..c93d7d78e51ab8e1e1379e1305477a75d37fdfa2 100644 (file)
@@ -15,7 +15,7 @@ define Device/airlink101_ar670w
   DEVICE_VENDOR := Airlink
   DEVICE_MODEL := AR670W
   IMAGE_SIZE := 3840k
-  KERNEL := $(KERNEL_DTB) | pad-to $$$$(BLOCKSIZE)
+  KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
        wrg-header wrgn16a_airlink_ar670w