qca-ssdk: add support for ipq60xx
authorRobert Marko <robimarko@gmail.com>
Sat, 14 Oct 2023 18:48:28 +0000 (20:48 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 9 Feb 2024 13:01:51 +0000 (14:01 +0100)
IPQ60xx uses a different codename for SSDK, so lets pass the correct one
as otherwise SSDK asumes we are building for the old MIPS SoC-s.

Signed-off-by: Robert Marko <robimarko@gmail.com>
[ drop outdated commit description info ]
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/kernel/qca-ssdk/Makefile

index 2517b80069c3f13cd1ae95c9d2aa93cbd2e8f69d..7eccdaa1d7d18f0bc73c4b618c6ea57a08225a17 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qca-ssdk
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE_URL:=https://git.codelinaro.org/clo/qsdk/oss/lklm/qca-ssdk.git
 PKG_SOURCE_PROTO:=git
@@ -53,6 +53,10 @@ ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")
     MAKE_FLAGS+= CHIP_TYPE=HPPE
 endif
 
+ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq60xx")
+    MAKE_FLAGS+= CHIP_TYPE=CPPE
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/qca-ssdk
        $(INSTALL_DIR) $(1)/usr/include/qca-ssdk/api