gemini: usb-fotg210: remove uneeded dependency on @USB_SUPPORT
authorRobert Marko <robimarko@gmail.com>
Wed, 8 Nov 2023 12:24:37 +0000 (13:24 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 8 Nov 2023 21:01:44 +0000 (22:01 +0100)
$(call AddDepends/usb) will add the dependency on @USB_SUPPORT so there
is no need to duplicate it.

Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/gemini/modules.mk

index 7b7e70d0699d9198dfc57b613a6492b6d84b10ab..5f544d12c786c083ce019058a406fd0e8a42842a 100644 (file)
@@ -1,6 +1,6 @@
 define KernelPackage/usb-fotg210
   TITLE:=Support for FOTG210 USB host and device controllers
-  DEPENDS:=@USB_SUPPORT @TARGET_gemini
+  DEPENDS:=@TARGET_gemini
   KCONFIG:= \
   CONFIG_USB_FOTG210 \
   CONFIG_USB_FOTG210_HCD=y \