ipq40xx: commonize Meraki recipe
authorRobert Marko <robimarko@gmail.com>
Mon, 14 Aug 2023 11:47:49 +0000 (13:47 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 14 Aug 2023 17:28:56 +0000 (19:28 +0200)
MR33 and MR74 share pretty much everything in the image recipe, so lets
extract a common recipe to avoid duplication.

Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/ipq40xx/image/generic.mk

index a9dd2aa0912f6abab4e80703e798b8740bd7e994..55e143e0dd8f4d65a8daae72a7e1cf2095d1d76e 100644 (file)
@@ -756,26 +756,25 @@ define Device/luma_wrtq-329acn
 endef
 TARGET_DEVICES += luma_wrtq-329acn
 
-define Device/meraki_mr33
+define Device/meraki_common
        $(call Device/FitImage)
        DEVICE_VENDOR := Cisco Meraki
-       DEVICE_MODEL := MR33
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+endef
+
+define Device/meraki_mr33
+       $(call Device/meraki_common)
+       DEVICE_MODEL := MR33
        DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr33
 
 define Device/meraki_mr74
-       $(call Device/FitImage)
-       DEVICE_VENDOR := Cisco Meraki
+       $(call Device/meraki_common)
        DEVICE_MODEL := MR74
-       SOC := qcom-ipq4029
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
        DEVICE_DTS_CONFIG := config@3
        DEFAULT := n
 endef