f2fs-tools: fix compilation with musl 1.2.4
authorTianling Shen <cnsztl@immortalwrt.org>
Tue, 16 May 2023 11:03:29 +0000 (19:03 +0800)
committerPetr Štetiar <ynezz@true.cz>
Tue, 16 May 2023 14:32:59 +0000 (16:32 +0200)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces and
autotools failed to check the lseek64 function.

Force enable ac_cv_func_lseek64 to workaround it.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
package/utils/f2fs-tools/Makefile

index 99d402af6ca552194138b3133c06f67d62939954..c4e3720dd8ddb49561d599676df41397653d31bb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=f2fs-tools
 PKG_VERSION:=1.15.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
@@ -111,6 +111,10 @@ endif
 CONFIGURE_VARS += \
        ac_cv_file__git=no
 
+ifneq ($(CONFIG_USE_MUSL),)
+  CONFIGURE_VARS += ac_cv_func_lseek64=yes
+endif
+
 define Package/libf2fs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) \