qca-ssdk: disable Malibu PHY in favor of upstream version
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 15 Nov 2023 00:07:18 +0000 (01:07 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 11 Feb 2024 20:09:34 +0000 (21:09 +0100)
Disable Malibu PHY driver in Qca SSDK in favor of the upstream version.
The same workaround are applied and the version upstream is just a drop
in replacement and is well tested from the ipq40xx target.

Also using the upstream version permits further support for LEDs.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/kernel/qca-ssdk/Makefile

index 7eccdaa1d7d18f0bc73c4b618c6ea57a08225a17..f1fb09c52a28639af6a91dfb316d3a31f13d97fc 100644 (file)
@@ -46,7 +46,7 @@ MAKE_FLAGS+= \
        SoC=$(CONFIG_TARGET_SUBTARGET) \
        PTP_FEATURE=disable SWCONFIG_FEATURE=disable \
        ISISC_ENABLE=disable IN_QCA803X_PHY=FALSE \
-       IN_QCA808X_PHY=FALSE \
+       IN_QCA808X_PHY=FALSE IN_MALIBU_PHY=FALSE \
        $(LNX_CONFIG_OPTS)
 
 ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")