ucode: update to latest Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Wed, 23 Nov 2022 13:15:19 +0000 (14:15 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 6 Dec 2022 10:43:06 +0000 (11:43 +0100)
46d93c9 tests: fixup testcases
4c654df types: adjust double printing format
eac2add compiler: fix bytecode for logical assignments of properties
3903b18 fs: add `realpath()` function
8366102 math: add isnan() function
eef83d3 tests: relax sleep() test
394e901 lib: uc_json(): accept trailing whitespace when parsing strings
1867c8b uloop: terminate parent uloop in task child processes
d2cc003 uci: auto-load package in `ctx.foreach()` and `ctx.get_first()`
6c5ee53 compiler: ensure that arrow functions with block bodies return no value
fdc9b6a compiler: fix `??=`, `||=` and `&&=` logical assignment semantics
88dcca7 add cmake to install requires for debian

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile

index eccf4aab32c6c53e9a5e053c7136fe0f9626e3fc..fafc449090b3c6176ce5d49ff8cafda712551fcc 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2022-10-18
-PKG_SOURCE_VERSION:=00af065057a0e9c10ce6a6475acc47920790c2a9
-PKG_MIRROR_HASH:=58077503b6cabe70334fca8f33f0e443c60de31a1aaadef7079d5d103c547fe1
+PKG_SOURCE_DATE:=2022-12-02
+PKG_SOURCE_VERSION:=46d93c9cc5da6fce581df86159bd0fc4357de41c
+PKG_MIRROR_HASH:=970a47f1bef719f056d40d17398db492bd4de92b98ef9aba4582cb18b4c9b270
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC