uboot-mediatek: fix dependency on TF-A for MT7988 RFB (sdmmc)
authorDaniel Golle <daniel@makrotopia.org>
Mon, 28 Aug 2023 22:41:43 +0000 (23:41 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 28 Aug 2023 22:43:49 +0000 (23:43 +0100)
The U-Boot build for the MT7988 reference board booting from SD card
wrongly depended on the 'ddr4' variant of the ARM TrustedFirmware-A build
even though the 'comb' variant is used. Fix that dependency.

Fixes: 572ea68070 ("uboot-mediatek: add patches for MT7988 and builds for RFB")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/uboot-mediatek/Makefile

index 021d444a97a54b4dcb773efdd724c9d176791f70..66de39218528513a7415b6fa5858b3fe7854d629 100644 (file)
@@ -403,7 +403,7 @@ define U-Boot/mt7988_rfb-sd
   BL2_BOOTDEV:=sdmmc
   BL2_SOC:=mt7988
   BL2_DDRTYPE:=comb
-  DEPENDS:=+trusted-firmware-a-mt7988-sdmmc-ddr4
+  DEPENDS:=+trusted-firmware-a-mt7988-sdmmc-comb
 endef
 
 UBOOT_TARGETS := \