armsr: armv8: fix invalid symbol value for FSL_ENETC_QOS
authorMathew McBride <matt@traverse.com.au>
Mon, 14 Aug 2023 06:13:28 +0000 (06:13 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 15 Aug 2023 13:55:00 +0000 (15:55 +0200)
The kernel FSL_ENETC_QOS option is only a compile time
option, it does not result in a separate module being built.

Set it to 'y' to resolve a warning from the kernel compile:

.config:2654:warning: symbol value 'm' invalid for FSL_ENETC_QOS

Signed-off-by: Mathew McBride <matt@traverse.com.au>
Fixes: c3151b6f045 ("armvirt: 64: add support for other SystemReady-compatible vendors")
target/linux/armsr/modules.mk

index 446b1483d2265d4939dc656becb6fa3c9d63c57d..6e9ecda9990cc2a581aa7d6522016bed3be582ea 100644 (file)
@@ -100,7 +100,7 @@ define KernelPackage/fsl-enetc-net
   KCONFIG:= \
     CONFIG_FSL_ENETC \
     CONFIG_FSL_ENETC_VF \
-    CONFIG_FSL_ENETC_QOS
+    CONFIG_FSL_ENETC_QOS=y
   FILES:= \
     $(LINUX_DIR)/drivers/net/ethernet/freescale/enetc/fsl-enetc.ko \
     $(LINUX_DIR)/drivers/net/ethernet/freescale/enetc/fsl-enetc-vf.ko \