target/imagebuilder: add help text and rename whatdepends to package_whatdepens
authorFlorian Eckert <fe@dev.tdt.de>
Thu, 19 Aug 2021 06:48:08 +0000 (08:48 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 6 Jan 2023 17:44:45 +0000 (18:44 +0100)
Add the command `package_whatdepends` to show all package that have a
dependency to this packages.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
target/imagebuilder/files/Makefile

index acf07a55186f3ddcedb5f85c6a59970530f72736..275932577b4c7024e4bb2e496f4c36cbdca0628d 100644 (file)
@@ -36,6 +36,7 @@ Available Commands:
        clean:  Remove images and temporary build files
        image:  Build an image (see below for more information).
        manifest: Show all package that will be installed into the image
+       package_whatdepends: Show which packages have a dependency on this
        package_depends: Show installation dependency of the package
 
 image:
@@ -59,6 +60,13 @@ manifest:
        make manifest PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make manifest STRIP_ABI=1 # remove ABI version from printed package names
 
+
+package_whatdepends:
+       List "all" packages that have a dependency on this package
+       You can use the following parameters:
+
+       make package_whatdepends PACKAGE="<pkg>"
+
 package_depends:
        List "all" packages dependency of the package
        You can use the following parameters:
@@ -263,7 +271,7 @@ manifest: FORCE
                $(if $(PROFILE),USER_PROFILE="$(PROFILE_FILTER)") \
                $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)"))
 
-whatdepends: FORCE
+package_whatdepends: FORCE
 ifeq ($(PACKAGE),)
        @echo 'Variable `PACKAGE` is not set but required by `whatdepends`'
        @exit 1
@@ -280,4 +288,4 @@ endif
        @$(OPKG) depends -A $(PACKAGE)
 
 
-.SILENT: help info image manifest whatdepends package_depends
+.SILENT: help info image manifest package_whatdepends package_depends