jansson: revert ABI version bump
authorJo-Philipp Wich <jo@mein.io>
Mon, 8 Aug 2022 22:08:13 +0000 (00:08 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 8 Aug 2022 22:20:09 +0000 (00:20 +0200)
The soversion of the shipped libjansson.so library didn't change, so the
ABI version change is unwarranted and leads to opkg file clashes.

Also stop shipping an unversioned library symlink while we're at it as
it only needed at compile/link time and leading to file level clashes
between packages on future ABI bumps.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/jansson/Makefile

index 4b0b7601c940db57d7a9be3c6d7cd221d00a46e7..6de48c1d86a8d85a172303773345085ef2d43bd6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=jansson
 PKG_VERSION:=2.14
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/akheron/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?
@@ -33,7 +33,7 @@ define Package/jansson
   CATEGORY:=Libraries
   TITLE:=Jansson library
   URL:=http://www.digip.org/jansson/
-  ABI_VERSION:=5
+  ABI_VERSION:=4
 endef
 
 define Package/jansson/description
@@ -45,7 +45,7 @@ TARGET_LDFLAGS += -flto
 
 define Package/jansson/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson*so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson*so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,jansson))