Revert "refpolicy: add variant that builds modular policy"
authorDaniel Golle <daniel@makrotopia.org>
Sun, 22 Nov 2020 15:20:35 +0000 (15:20 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 22 Nov 2020 15:20:35 +0000 (15:20 +0000)
This reverts commit 9eb9943f82e0b2d5e32ffe1c63f5a82caca5094d.
Building the 'modular' variant requires 'semodule_package' from
'selinux-python' to be installed on the buildhost.
Apart from that, this change also broke the monolithic refpolicy
'targeted' build.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
config/Config-build.in
package/system/refpolicy/Makefile

index 178afbdb94de489e629bd451a92b3d9b3dec75ba..8e12199cbd118825cbfecf067242b2695af02f52 100644 (file)
@@ -362,12 +362,6 @@ menu "Global build settings"
                        help
                          SELinux Reference Policy (refpolicy)
 
-               config SELINUXTYPE_targeted-modular
-                       bool "targeted-modular"
-                       select PACKAGE_refpolicy-modular
-                       help
-                         Modular SELinux Reference Policy (refpolicy-modular)
-
                config SELINUXTYPE_dssp
                        bool "dssp"
                        select PACKAGE_selinux-policy
index d9c8c90208dcb5f8e27ddcf28ac2c69d2e2a077a..a43177095517c6023a3f9477e7fb335c4a2f95df 100644 (file)
@@ -24,7 +24,7 @@ TAR_OPTIONS:=--transform='s%^refpolicy%$(PKG_NAME)-$(PKG_VERSION)%' -xf -
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/refpolicy/Default
+define Package/refpolicy
   SECTION:=system
   CATEGORY:=Base system
   TITLE:=SELinux reference policy
@@ -32,19 +32,6 @@ define Package/refpolicy/Default
   PKGARCH:=all
 endef
 
-define Package/refpolicy
-  $(call Package/refpolicy/Default)
-  CONFLICTS:=refpolicy-modular
-  VARIANT:=default
-endef
-
-define Package/refpolicy-modular
-  $(call Package/refpolicy/Default)
-  TITLE += (modular)
-  VARIANT:=modular
-  PROVIDES:=refpolicy
-endef
-
 define Package/refpolicy/description
        The SELinux Reference Policy project (refpolicy) is a
        complete SELinux policy that can be used as the system
@@ -69,43 +56,25 @@ endef
 # builds is a small host tool that gets run as part of the build
 # process.
 MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)"
        SETFILES="$(STAGING_DIR_HOST)/bin/setfiles" \
        CHECKPOLICY="$(STAGING_DIR_HOSTPKG)/bin/checkpolicy" \
        CC="$(HOSTCC)" \
        CFLAGS="$(HOST_CFLAGS)"
 
 define Build/Configure
-       $(SED) "/NAME/c\NAME = targeted" $(PKG_BUILD_DIR)/build.conf
-ifneq ($(BUILD_VARIANT),modular)
        $(SED) "/MONOLITHIC/c\MONOLITHIC = y" $(PKG_BUILD_DIR)/build.conf
-endif
+       $(SED) "/NAME/c\NAME = targeted" $(PKG_BUILD_DIR)/build.conf
        $(call Build/Compile/Default,conf)
 endef
 
-ifeq ($(BUILD_VARIANT),modular)
-define Build/Install
-       $(call Build/Compile/Default,install install-headers)
-endef
-endif
-
 define Package/refpolicy/conffiles
 /etc/selinux/config
 endef
 
-Package/refpolicy-modular/conffiles = $(Package/refpolicy/conffiles)
-
 define Package/refpolicy/install
        $(INSTALL_DIR) $(1)/etc/selinux
        $(CP) $(PKG_INSTALL_DIR)/etc/selinux/* $(1)/etc/selinux/
        $(CP) ./files/selinux-config $(1)/etc/selinux/config
-ifeq ($(BUILD_VARIANT),modular)
-       $(INSTALL_DIR) $(1)/usr/share/selinux
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/selinux/* $(1)/usr/share/selinux/
-endif
 endef
 
-Package/refpolicy-modular/install = $(Package/refpolicy/install)
-
 $(eval $(call BuildPackage,refpolicy))
-$(eval $(call BuildPackage,refpolicy-modular))