libevent2: trigger rebuild on libevent2-pthreads
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 29 Dec 2020 17:13:50 +0000 (19:13 +0200)
committerPaul Spooren <mail@aparcar.org>
Fri, 1 Jan 2021 20:26:20 +0000 (10:26 -1000)
The symbol determines if the libevent2-pthreads libraries get built or not.
If we want to select libevent2-pthreads, and these haven't been built, an
error will occur mentioning that there are no 'libevent_pthreads-2.1.so'
files.

Adding CONFIG_PACKAGE_libevent2-pthreads to PKG_CONFIG_DEPEND will make
sure that the libraries get re-built in case libevent2-pthreads is
selected.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
package/libs/libevent2/Makefile

index b949c9f9d6a61c0cee98306073cb2a6c6127e665..701840a871e49bdd532c18615b9343c7775f82d0 100644 (file)
@@ -23,6 +23,7 @@ PKG_CPE_ID:=cpe:/a:libevent_project:libevent
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_libevent2-openssl \
+       CONFIG_PACKAGE_libevent2-pthreads \
        CONFIG_PACKAGE_libevent2-mbedtls
 
 include $(INCLUDE_DIR)/package.mk