upgs: Remove extra _DEFAULT_SOURCE definition
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 18 Apr 2020 15:42:02 +0000 (17:42 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 4 May 2020 22:05:28 +0000 (00:05 +0200)
This extra _DEFAULT_SOURCE definition results in a double definition
which is a compile error.

This fixes the following compile error with glibc:
----------------------------------------------------------------------
ugps-2019-06-25-cd7eabcd/nmea.c:19: error: "_DEFAULT_SOURCE" redefined [-Werror]
 #define _DEFAULT_SOURCE

<command-line>: note: this is the location of the previous definition
cc1: all warnings being treated as errors

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 70a962ca6f13e82d8d67f5c8ee65064a41f66a9c)

package/utils/ugps/Makefile

index 6eae5afbcf5bb7a76e9012b011909a967e03355a..85c64533d1dc2bd54765c12ec2d391c2d31ba45a 100644 (file)
@@ -31,10 +31,6 @@ endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 
-ifneq ($(CONFIG_USE_GLIBC),)
-  TARGET_CFLAGS += -D_DEFAULT_SOURCE
-endif
-
 define Package/ugps/conffiles
 /etc/config/gps
 endef