realtek: Do not set KERNEL_ENTRY just to avoid NO_EXCEPT_FILL
authorOlliver Schinagl <oliver@schinagl.nl>
Sun, 8 Jan 2023 16:30:07 +0000 (17:30 +0100)
committerSander Vanheule <sander@svanheule.net>
Tue, 24 Jan 2023 20:00:19 +0000 (21:00 +0100)
It seems like we are offsetting the KERNEL_ENTRY to +0x400, which is
also accomplished by the NO_EXCEPT_FILL configuration option.

Since this is the default for MIPS_GENERIC_KERNEL, lets push a little
bit closer to that one by doing the same thing.

Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
target/linux/realtek/image/Makefile
target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch

index 3dfbcf67c166807bb400923116fa232b176e5055..a2afb39d406a441ea1471baf5691a0e9e57ab277 100644 (file)
@@ -4,7 +4,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR = 0x80100000
-KERNEL_ENTRY = 0x80100400
 
 DEVICE_VARS += \
         CAMEO_BOARD_VERSION \
index 3834ba7c61941d29d77a9fd155dcffab30094cf3..f54bd28242c85137fc8d8ba32a21217da0bd4bb1 100644 (file)
@@ -25,7 +25,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
  platform-$(CONFIG_SGI_IP28)           += sgi-ip22/
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1037,8 +1037,58 @@ config NLM_XLP_BOARD
+@@ -1037,8 +1037,59 @@ config NLM_XLP_BOARD
          This board is based on Netlogic XLP Processor.
          Say Y here if you have a XLP based board.
  
@@ -33,6 +33,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
 +      bool "Realtek based platforms"
 +      select DMA_NONCOHERENT
 +      select IRQ_MIPS_CPU
++      select NO_EXCEPT_FILL
 +      select SYS_HAS_CPU_MIPS32_R1
 +      select SYS_HAS_CPU_MIPS32_R2
 +      select SYS_SUPPORTS_BIG_ENDIAN
index 3929096888b53c4d65770a06457f17de9101854f..8428c32e4e0af1f43621514b4807d00c0b938511 100644 (file)
@@ -25,7 +25,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
  platform-$(CONFIG_SGI_IP28)           += sgi-ip22/
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1053,8 +1053,58 @@ config NLM_XLP_BOARD
+@@ -1053,8 +1053,59 @@ config NLM_XLP_BOARD
          This board is based on Netlogic XLP Processor.
          Say Y here if you have a XLP based board.
  
@@ -33,6 +33,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
 +      bool "Realtek based platforms"
 +      select DMA_NONCOHERENT
 +      select IRQ_MIPS_CPU
++      select NO_EXCEPT_FILL
 +      select SYS_HAS_CPU_MIPS32_R1
 +      select SYS_HAS_CPU_MIPS32_R2
 +      select SYS_SUPPORTS_BIG_ENDIAN