mediatek: mt7622: convert unifi6lr-v{1,2,3}-ubootmod to fitblk
authorDaniel Golle <daniel@makrotopia.org>
Mon, 22 Jan 2024 00:56:47 +0000 (00:56 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 15 Feb 2024 19:30:08 +0000 (19:30 +0000)
No bootloader changes needed in this case, smooth transition.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/uboot-envtools/files/mediatek_mt7622
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1-ubootmod.dts
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v2-ubootmod.dts
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v3-ubootmod.dts
target/linux/mediatek/image/mt7622.mk
target/linux/mediatek/mt7622/base-files/lib/upgrade/platform.sh

index 732f7d5a0e5f8d466d530251fb706546e8220bc4..b4b1698d3fddde0d3de177bbbca2a346a95c8b96 100644 (file)
@@ -52,8 +52,10 @@ buffalo,wsr-2533dhp2)
 ruijie,rg-ew3200gx-pro)
        ubootenv_add_uci_config "/dev/mtd3" "0x0" "0x20000" "0x20000"
        ;;
-ubnt,unifi-6-lr-ubootmod)
-       ubootenv_add_uci_config "/dev/mtd2" "0x0" "0x4000" "0x1000"
+ubnt,unifi-6-lr-v1-ubootmod|\
+ubnt,unifi-6-lr-v2-ubootmod|\
+ubnt,unifi-6-lr-v3-ubootmod)
+       ubootenv_add_uci_config "/dev/mtd$(find_mtd_index "u-boot-env")" "0x0" "0x4000" "0x1000"
        ;;
 xiaomi,redmi-router-ax6s)
        ubootenv_add_uci_config "/dev/mtd3" "0x0" "0x10000" "0x40000"
index 7a7a8a815911ea1c093f5aab5d036203a4a11c16..5f62ed1a455029c5f2b17304b4510c1ff7b6e744 100644 (file)
@@ -5,6 +5,11 @@
 / {
        model = "Ubiquiti UniFi 6 LR v1 (U-Boot mod)";
        compatible = "ubnt,unifi-6-lr-v1-ubootmod", "mediatek,mt7622";
+
+       chosen {
+               rootdisk = <&rootdisk>;
+               bootargs = "earlycon=uart8250,mmio32,0x11002000 swiotlb=512 console=ttyS0,115200n8 root=/dev/fit0";
+       };
 };
 
 &nor_partitions {
@@ -54,7 +59,7 @@
                reg = <0x120000 0xee0000>;
        };
 
-       partition@1000000 {
+       rootdisk: partition@1000000 {
                compatible = "denx,fit";
                label = "firmware";
                reg = <0x1000000 0x3000000>;
index 3a37d1d5004f0f4eac38f0835738b2e25f71353a..96effb8aab411784794811cfc7eb8b997513f71d 100644 (file)
@@ -5,6 +5,11 @@
 / {
        model = "Ubiquiti UniFi 6 LR v2 (U-Boot mod)";
        compatible = "ubnt,unifi-6-lr-v2-ubootmod", "mediatek,mt7622";
+
+       chosen {
+               rootdisk = <&rootdisk>;
+               bootargs = "earlycon=uart8250,mmio32,0x11002000 swiotlb=512 console=ttyS0,115200n8 root=/dev/fit0";
+       };
 };
 
 &nor_partitions {
@@ -54,7 +59,7 @@
                reg = <0x120000 0xee0000>;
        };
 
-       partition@1000000 {
+       rootdisk: partition@1000000 {
                compatible = "denx,fit";
                label = "firmware";
                reg = <0x1000000 0x3000000>;
index e91aaa63f58bdf6fc212c8f398fd2b416c514933..ec98dd262cfb36e033b3858dd24b0ae5d2fa328c 100644 (file)
@@ -5,6 +5,11 @@
 / {
        model = "Ubiquiti UniFi 6 LR v3 (U-Boot mod)";
        compatible = "ubnt,unifi-6-lr-v3-ubootmod", "mediatek,mt7622";
+
+       chosen {
+               rootdisk = <&rootdisk>;
+               bootargs = "earlycon=uart8250,mmio32,0x11002000 swiotlb=512 console=ttyS0,115200n8 root=/dev/fit0";
+       };
 };
 
 &nor_partitions {
@@ -54,7 +59,7 @@
                reg = <0x120000 0xee0000>;
        };
 
-       partition@1000000 {
+       rootdisk: partition@1000000 {
                compatible = "denx,fit";
                label = "firmware";
                reg = <0x1000000 0x3000000>;
index 0d631c19963ecdd9badf3d89a1c2716a759f1654..dd86c167de4b6475344ca937ca25286e777b49df 100644 (file)
@@ -375,7 +375,7 @@ define Device/ubnt_unifi-6-lr-v1-ubootmod
   DEVICE_VARIANT := v1 U-Boot mod
   DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1-ubootmod
   DEVICE_DTS_DIR := ../dts
-  DEVICE_PACKAGES := kmod-mt7915-firmware kmod-leds-ubnt-ledbar
+  DEVICE_PACKAGES := fitblk kmod-mt7915-firmware kmod-leds-ubnt-ledbar
   KERNEL := kernel-bin | lzma
   KERNEL_INITRAMFS_SUFFIX := -recovery.itb
   KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
@@ -405,7 +405,7 @@ define Device/ubnt_unifi-6-lr-v2-ubootmod
   DEVICE_VARIANT := v2 U-Boot mod
   DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v2-ubootmod
   DEVICE_DTS_DIR := ../dts
-  DEVICE_PACKAGES := kmod-mt7915-firmware
+  DEVICE_PACKAGES := fitblk kmod-mt7915-firmware
   KERNEL := kernel-bin | lzma
   KERNEL_INITRAMFS_SUFFIX := -recovery.itb
   KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
@@ -434,7 +434,7 @@ define Device/ubnt_unifi-6-lr-v3-ubootmod
   DEVICE_VARIANT := v3 U-Boot mod
   DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v3-ubootmod
   DEVICE_DTS_DIR := ../dts
-  DEVICE_PACKAGES := kmod-mt7915-firmware
+  DEVICE_PACKAGES := fitblk kmod-mt7915-firmware
   KERNEL := kernel-bin | lzma
   KERNEL_INITRAMFS_SUFFIX := -recovery.itb
   KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
index 5836e1aa3ee4685d862e832f03fa101fcd05db57..6417eb1a3a76d982c3b80a109f7a541aaffb9ace 100755 (executable)
@@ -21,7 +21,10 @@ platform_do_upgrade() {
        local file_type=$(identify $1)
 
        case "$board" in
-       bananapi,bpi-r64)
+       bananapi,bpi-r64|\
+       ubnt,unifi-6-lr-v1-ubootmod|\
+       ubnt,unifi-6-lr-v2-ubootmod|\
+       ubnt,unifi-6-lr-v3-ubootmod)
                [ -e /dev/fit0 ] && fitblk /dev/fit0
                [ -e /dev/fitrw ] && fitblk /dev/fitrw
                bootdev="$(platform_get_bootdev)"
@@ -30,6 +33,10 @@ platform_do_upgrade() {
                        EMMC_KERN_DEV="/dev/$bootdev"
                        emmc_do_upgrade "$1"
                        ;;
+               mtdblock*)
+                       PART_NAME="/dev/mtd${bootdev:8}"
+                       default_do_upgrade "$1"
+                       ;;
                ubiblock*)
                        CI_KERNPART="fit"
                        nand_do_upgrade "$1"