mediatek: filogic: replace built-in Aquantia driver with module
authorRafał Miłecki <rafal@milecki.pl>
Wed, 17 Jan 2024 21:20:15 +0000 (22:20 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Sat, 17 Feb 2024 16:54:07 +0000 (17:54 +0100)
Some Aquantia PHYs (e.g. AQR113C) require firmware to be uploaded by
host system. With built-in drivers this doesn't work in OpenWrt /
embeddded as filesystem isn't available during PHY probe. That results
in delays like:
[    1.588068] Aquantia AQR113C mdio-bus:00: Falling back to sysfs fallback for: Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld
[   64.526387] Aquantia AQR113C mdio-bus:00: failed to find FW file Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld (-110)

Switch to module to postpone PHY probe to init state.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/mediatek/filogic/config-6.1
target/linux/mediatek/filogic/target.mk

index 9e27cd830cce63959dbf96c2c1d01c87c1f52868..34aa2e76b66d8fc98d64a36b8deaf51e512bc641 100644 (file)
@@ -1,6 +1,5 @@
 CONFIG_64BIT=y
 # CONFIG_AHCI_MTK is not set
-CONFIG_AQUANTIA_PHY=y
 CONFIG_ARCH_BINFMT_ELF_EXTRA_PHDRS=y
 CONFIG_ARCH_CORRECT_STACKTRACE_ON_KRETPROBE=y
 CONFIG_ARCH_DMA_ADDR_T_64BIT=y
index dd4c4c1448347c1d69ee53679a1c09b4011b5732..182b229db259c2dbe75cecd4198bc1907f25a364 100644 (file)
@@ -2,7 +2,7 @@ ARCH:=aarch64
 SUBTARGET:=filogic
 BOARDNAME:=Filogic 8x0 (MT798x)
 CPU_TYPE:=cortex-a53
-DEFAULT_PACKAGES += kmod-crypto-hw-safexcel kmod-mt7915e wpad-basic-mbedtls uboot-envtools
+DEFAULT_PACKAGES += kmod-phy-aquantia kmod-crypto-hw-safexcel kmod-mt7915e wpad-basic-mbedtls uboot-envtools
 KERNELNAME:=Image dtbs
 
 define Target/Description