acx-mac80211: set DL_DIR to package specific subdirectory
authorMichael Pratt <mcpratt@pm.me>
Mon, 5 Sep 2022 20:00:42 +0000 (16:00 -0400)
committerMichael Pratt <mcpratt@pm.me>
Thu, 22 Sep 2022 20:48:36 +0000 (16:48 -0400)
This package downloads raw files
which have names that are not corresponding to
the name and version of the package
as it is defined in the Makefile.

Use the option DL_SUBDIR to set the DL_DIR
to be a subdirectory named with
PKG_NAME and PKG_SOURCE_DATE
to better organize the downloads.

Define PKG_VERSION here
using PKG_SOURCE_DATE.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
package/kernel/acx-mac80211/Makefile

index 8bb84e5a6ae5df57cfbcf65a723692763b32821e..240f171d1eda3d902bab475b590ba4b18a7b3a29 100644 (file)
@@ -17,6 +17,8 @@ PKG_SOURCE_DATE:=2014-02-16
 PKG_SOURCE_VERSION:=b6fc31491020cb01d2cd1acc170cfa03ced7e726
 PKG_MIRROR_HASH:=58590245715f0e5fb4b57aab6d91071dfb6a97d3273f5aee0b97b1edee030ed0
 
+DL_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_DATE)
+
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_MAC80211_DEBUGFS \
        CONFIG_PACKAGE_MAC80211_MESH \