build: replace `true` with a custom noop script
authorIlya Katsnelson <me@0upti.me>
Sun, 29 Oct 2023 22:39:31 +0000 (01:39 +0300)
committerDavid Bauer <mail@david-bauer.net>
Fri, 3 Nov 2023 22:06:07 +0000 (23:06 +0100)
`true` might be a shell built-in, or simply not accessible in the hardcoded locations.
Replace it with a custom script that does nothing.

Signed-off-by: Ilya Katsnelson <me@0upti.me>
include/prereq-build.mk
scripts/noop.sh [new file with mode: 0755]

index e5f20fff22e282b0dd72f3b951b3becf5af30308..49340ce3e441ccbaa1833d6eb38d8abd450f627e 100644 (file)
@@ -238,4 +238,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       $(LN) $(firstword $(wildcard /bin/true /usr/bin/true)) $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) $(SCRIPT_DIR)/noop.sh $(STAGING_DIR_HOST)/bin/ldconfig))
diff --git a/scripts/noop.sh b/scripts/noop.sh
new file mode 100755 (executable)
index 0000000..96b71fe
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+# This script does nothing, intentionally.