imx: add gpio-button-hotplug to ventana images
authorTim Harvey <tharvey@gateworks.com>
Wed, 15 Mar 2023 19:56:56 +0000 (12:56 -0700)
committerRobert Marko <robimarko@gmail.com>
Thu, 15 Feb 2024 20:21:11 +0000 (21:21 +0100)
Add the gpio-button-hotplug to Gateworks ventana images to support
the on-board user pushbutton.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
target/linux/imx/image/cortexa9.mk

index 2edbbaac4765cf56eb5a88a61a84bffb80913195..2321469cc861e8919a8a8d7880a3e3eabb5018ee 100644 (file)
@@ -120,7 +120,8 @@ define Device/gateworks_ventana
        imx6q-gw5913
   DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx \
        kmod-sound-soc-imx-sgtl5000 kmod-can kmod-can-flexcan kmod-can-raw \
-       kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng
+       kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng \
+       kmod-gpio-button-hotplug
   KERNEL += | boot-overlay
   IMAGES := img.gz nand.ubi bootfs.tar.gz dtb
   IMAGE/nand.ubi := append-ubi