Revert "build: replace which with Bash command built-in"
authorClemens Fruhwirth <clemens@endorphin.org>
Fri, 29 Jan 2021 18:57:37 +0000 (19:57 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Mar 2021 21:51:39 +0000 (22:51 +0100)
This reverts commit c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb.

The original commit replaces 'which' with 'command'. Sadly most of
them are not equivalent and for 'which -a', there is no easy
replacements that would not reimplement PATH parsing logic. Hence
revert. Keeping a dependency on which is absolutely fine.

Signed-off-by: Clemens Fruhwirth <clemens@endorphin.org>
Makefile
include/cmake.mk
include/prereq.mk

index aecee6929e29add4a161f70f5bfd80f7e02b8568..e18bc18608a171158aa268a90553804fa088cc22 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
 
 world:
 
-DISTRO_PKG_CONFIG:=$(shell command -pv pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
 export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)
index de8022ca57346d2b2a71cb4d1e712fba0499d909..96c4d7df3479f2e8f9941573738e18895708d1c9 100644 (file)
@@ -15,7 +15,7 @@ MAKE_PATH = $(firstword $(CMAKE_BINARY_SUBDIR) .)
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   cmake_tool=$(TOOLCHAIN_DIR)/bin/$(1)
 else
-  cmake_tool=$(shell command -v $(1))
+  cmake_tool=$(shell which $(1))
 endif
 
 ifeq ($(CONFIG_CCACHE),)
index c11178a884b4b450ee4fb585785a3ec1bb0cd998..23d5ded9b272b59e0c7700ed32ff4dd22b23dd22 100644 (file)
@@ -49,7 +49,7 @@ endef
 
 define RequireCommand
   define Require/$(1)
-    command -pv $(1)
+    which $(1)
   endef
 
   $$(eval $$(call Require,$(1),$(2)))
@@ -103,7 +103,7 @@ define SetupHostCommand
                   $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
-                               command -pv "$$$$$$$${cmd%% *}")"; \
+                               which "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
                                mkdir -p "$(STAGING_DIR_HOST)/bin"; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \