qca-ssdk: disable building ISISC
authorRobert Marko <robimarko@gmail.com>
Tue, 14 Nov 2023 13:51:14 +0000 (14:51 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 15 Nov 2023 10:01:56 +0000 (11:01 +0100)
ISISC is the QCA codename for their Atheros switch family including
AR237, QCA8337 etc.

Since we have qca8k support in OpenWrt, there is no need to have SSDK
support for these switches, and boards that also have external switches
can just use qca8k.

Disable QCA803x PHY support as well, since all of those are supportable
via at803x driver.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/qca-ssdk/Makefile

index 3770d29e8c5dd0e88036807c7d9e9062953a9605..d8c8d6cb167c1d5cce8489309061d4804b189cf3 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=qca-ssdk
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=https://git.codelinaro.org/clo/qsdk/oss/lklm/qca-ssdk.git
 PKG_SOURCE_PROTO:=git
@@ -45,6 +45,7 @@ MAKE_FLAGS+= \
        EXTRA_CFLAGS=-fno-stack-protector -I$(STAGING_DIR)/usr/include \
        SoC=$(CONFIG_TARGET_SUBTARGET) \
        PTP_FEATURE=disable SWCONFIG_FEATURE=disable \
+       ISISC_ENABLE=disable IN_QCA803X_PHY=FALSE \
        $(LNX_CONFIG_OPTS)
 
 ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")