tools/coreutils: rename list of installed programs
authorMichael Pratt <mcpratt@pm.me>
Tue, 30 May 2023 09:22:54 +0000 (05:22 -0400)
committerPetr Štetiar <ynezz@true.cz>
Mon, 5 Jun 2023 06:31:56 +0000 (08:31 +0200)
Rename the list of programs installed by coreutils
to PKG_PROGRAMS, which will create a stampfile for each
through a new feature in host-build.mk.

Also, cleanup a bit to save lines
regarding the usage of this list.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/coreutils/Makefile

index 233ab1585d75af954dd501348d890922628612a4..863028620602393c1ab4ecef9613f3b0813775cd 100644 (file)
@@ -16,20 +16,18 @@ PKG_HASH:=adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa
 
 HOST_BUILD_PARALLEL := 1
 
-BUILD_PROGRAMS = date readlink touch ln chown ginstall
+PKG_PROGRAMS:=date readlink touch ln chown ginstall
 
 include $(INCLUDE_DIR)/host-build.mk
 
 export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
 
-BUILD_BINS = $(patsubst %,src/%,$(BUILD_PROGRAMS))
-
 HOST_CONFIGURE_ARGS += \
-        --enable-install-program=$(subst $(space),$(comma),$(strip $(BUILD_PROGRAMS)))
+        --enable-install-program=$(subst $(space),$(comma),$(strip $(PKG_PROGRAMS)))
 
 HOST_MAKE_FLAGS += \
        $(AM_TOOL_PATHS_FAKE) \
-       PROGRAMS="$(BUILD_BINS)" \
+       PROGRAMS="$(patsubst %,src/%,$(PKG_PROGRAMS))" \
        LIBRARIES= MANS= SUBDIRS=.
 
 define Host/Bootstrap
@@ -58,7 +56,7 @@ endef
 
 define Host/Install
        $(INSTALL_DIR) $(1)/bin
-       $(INSTALL_BIN) $(patsubst %,$(HOST_BUILD_DIR)/%,$(BUILD_BINS)) $(1)/bin/
+       $(INSTALL_BIN) $(patsubst %,$(HOST_BUILD_DIR)/src/%,$(PKG_PROGRAMS)) $(1)/bin/
        ln -sf ginstall $(1)/bin/install
 endef