ucode: update to latest Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Mon, 7 Feb 2022 09:19:02 +0000 (10:19 +0100)
committerJo-Philipp Wich <jo@mein.io>
Mon, 7 Feb 2022 10:44:36 +0000 (11:44 +0100)
11adf0c source: convert source objects into proper uc_value_t type
3a49192 treewide: rework function memory model
7edad5c tests: add functional tests for builtin functions
d5003fd lib: fix leaking tokener in uc_json() on parse exception
5d0ecd9 lib: fix infinite loop on empty regexp matches in uc_replace()
3ad57f1 lib: fix infinite loop on empty regexp matches in uc_match()
32d596d lib: fix infinite loop on empty regexp matches in uc_split()
3e3f38d vm: ensure consistent trace output between gcc and clang compiled ucode
3600ded vm: fix leaking function value on call exception
3059295 vm: NULL-initialize pointer to make cppcheck happy
98e59bf source: zero-initialize conversion union to make cppcheck happy
7a65c14 run_tests.sh: change workdir to testcase directory during execution
afec8d7 run_tests.sh: support placing supplemental testcase files
3ada6e0 run_tests.sh: always treat outputs as text data
2cb627f program: rename bytecode load/write functions, track path of executed file
1094ffa lib: fix memory leak in uc_require_ucode()

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile

index f53a3a352956edd4817f213569f5da2f7d55f609..4d66cc9f6c91263fd468a00b839ad5381c3740cb 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2022-01-26
-PKG_SOURCE_VERSION:=ddc5aa7cd3121300f2ba6e68cb038258a616d4e4
-PKG_MIRROR_HASH:=f9a3c010c54288a2363757b58ef31a827b8314e444bb7bf48926f7d4ea88b9d6
+PKG_SOURCE_DATE:=2022-02-07
+PKG_SOURCE_VERSION:=11adf0c4ea91e63ec523849c2846fd07bf4348f5
+PKG_MIRROR_HASH:=cd7639cb08ead23c1d659e293ec90fda733785ee5432c3a1d7d54df17e0f6d20
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC