wireguard-tools: avoid redundant jsonfilter calls
authorJo-Philipp Wich <jo@mein.io>
Tue, 23 Jan 2024 08:19:35 +0000 (09:19 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 23 Jan 2024 08:19:35 +0000 (09:19 +0100)
Use a single jsonfilter expression to yield the list of logical wireguard
interface names in shell compatible notation.

Supersedes: #12344
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/utils/wireguard-tools/Makefile
package/network/utils/wireguard-tools/files/wireguard_watchdog

index 5b1fab057d937a517e4dbfd8e2277d566f7e81c0..e2a86c97d8d26e58184b93793a932545bf2b6e61 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=wireguard-tools
 
 PKG_VERSION:=1.0.20210914
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=wireguard-tools-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/wireguard-tools/snapshot/
index 0126f699bb433e75bdc2ebb62b8a27a56769ba01..fc90f4a25b3564fb7a4cd3b464266d374c32f374 100644 (file)
@@ -59,7 +59,7 @@ check_peer_activity() {
 }
 
 # query ubus for all active wireguard interfaces
-wg_ifaces=$(ubus -S call network.interface dump | jsonfilter -e '@.interface[@.up=true]' | jsonfilter -a -e '@[@.proto="wireguard"].interface' | tr "\n" " ")
+eval $(ubus -S call network.interface dump | jsonfilter -e 'wg_ifaces=@.interface[@.up=true && @.proto="wireguard"].interface')
 
 # check every peer in every active wireguard interface
 config_load network