build: use CCACHE_DIR for ccache directory
authorSven Wegener <sven.wegener@stealer.net>
Fri, 1 Jan 2021 10:43:50 +0000 (11:43 +0100)
committerPaul Spooren <mail@aparcar.org>
Fri, 1 Jan 2021 23:31:11 +0000 (13:31 -1000)
It is being set by rules.mk with the same expression.

Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
Makefile

index 24f5955c906652e62880bf2c001de32d0c065219..4ccbc20b85803600206f6f1e365bbdf492915312 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,7 @@ dirclean: clean
 
 cacheclean:
 ifneq ($(CONFIG_CCACHE),)
-       rm -rf $(if $(call qstrip,$(CONFIG_CCACHE_DIR)),$(call qstrip,$(CONFIG_CCACHE_DIR)),$(TOPDIR)/.ccache)
+       rm -rf $(CCACHE_DIR)
 endif
 
 ifndef DUMP_TARGET_DB