ucode: update to latest Git HEAD
authorJo-Philipp Wich <jo@mein.io>
Mon, 29 Mar 2021 10:50:55 +0000 (12:50 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 29 Mar 2021 10:51:40 +0000 (12:51 +0200)
aa9621d compiler: rework switch statement code generation
b5f0de1 vm: add trace mode instruction dump output fixes
0341d64 vm: fix another for-loop memory leak
00d9419 vm: fix further memory leaks in trace mode
20a3763 vm: fix loop variable memory leak in NEXTK/NEXTKV instruction
9a6ef2b lib: prevent use-after-free after uc_shift()
03f1324 object: free prototype object when registering existing ressource type
b3d758b compiler: fix for/break miscompilation
86e3970 lib: fix value refcount of uc_unshift() return value
fe464ea run_tests.sh: allow passing tests to run as arguments
091ae1b compiler: fix another try/catch miscompilation
fcedb19 lib: fix passing uninitialized memory to sigprocmask()
0d0357d vm: fix leaking source context strings in trace mode
7a41fb3 lib: use execvp() in system()

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile

index 6fb9f73c3dd477c204055b790c6925bc5a7190ec..8ecfef01c5dba02aa141fe4db07fd08d31c735d1 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2021-03-19
-PKG_SOURCE_VERSION:=4a5b9010ccc56fdf288fe758023af445feb93fad
-PKG_MIRROR_HASH:=2d15fe2f51ebdeae532a2e8130689400cf2364876e737cfbb1bf9c045719acf1
+PKG_SOURCE_DATE:=2021-03-29
+PKG_SOURCE_VERSION:=aa9621db401e881ffcdea03be272c94149484ccf
+PKG_MIRROR_HASH:=11b7de10e6ab91742d8a633a0030dde86118ffe73031cdf9c192cb3fded97a20
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC