wolfssl: make shared again
authorJo-Philipp Wich <jo@mein.io>
Sun, 24 Jul 2022 11:23:36 +0000 (13:23 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Jul 2022 10:21:54 +0000 (12:21 +0200)
Disable the usage of target specific CPU crypto instructions by default
to allow the package being shared again. Since WolfSSL does not offer
a stable ABI or a long term support version suitable for OpenWrt release
timeframes, we're forced to frequently update it which is greatly
complicated by the package being nonshared.

People who want or need CPU crypto instruction support can enable it in
menuconfig while building custom images for the few platforms that support
them.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/wolfssl/Config.in
package/libs/wolfssl/Makefile

index 332a151550f44fd157891c3b4ffb5697ec477a5a..4b9db4d1079b403407be9b1395dd1467186a5a46 100644 (file)
@@ -72,7 +72,6 @@ config WOLFSSL_ASM_CAPABLE
 
 choice
        prompt "Hardware Acceleration"
-       default WOLFSSL_HAS_CPU_CRYPTO if WOLFSSL_ASM_CAPABLE && !TARGET_armvirt
        default WOLFSSL_HAS_NO_HW
 
        config WOLFSSL_HAS_NO_HW
index 55928f1446874779d8a0063c3362ff2bcd0a2711..b0e100673cb10563d7d28834e172b84d2dd6e3d6 100644 (file)
@@ -61,7 +61,6 @@ endef
 define Package/libwolfssl
 $(call Package/libwolfssl/Default)
   TITLE:=wolfSSL library
-  PKGFLAGS:=nonshared
   MENU:=1
   PROVIDES:=libcyassl
   DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user