kernel: move CONFIG_RTC to generic configs lede-17.01-queue
authorJonas Gorski <jonas.gorski@gmail.com>
Thu, 20 Jun 2019 09:37:51 +0000 (11:37 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Thu, 20 Jun 2019 09:48:51 +0000 (11:48 +0200)
RTC (the legacy driver) should not really be used, but seems to crop up
after the kernel update. Fix this by disabling it in the generic config.

Fixes the following build issue seen in arm64 or powerpc64:

ARM JTAG DCC console (HVC_DCC) [N/y/?] n
Virtio console (VIRTIO_CONSOLE) [N/m/y/?] n
Enhanced Real Time Clock Support (legacy PC RTC driver) (RTC) [N/m/y/?] (NEW) aborted!

Console input/output is redirected. Run 'make oldconfig' to update configuration.

scripts/kconfig/Makefile:37: recipe for target 'silentoldconfig' failed

Fixes: 6c5c3a2edccf ("kernel: Update to version 4.4.182")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
target/linux/arc770/config-4.4
target/linux/archs38/config-4.4
target/linux/generic/config-4.4

index f484de30be3c8584aa38cdc229c4690f27f73d2f..6b5407e9f0e497d5f61e8ae8083d28633e33b2a4 100644 (file)
@@ -154,7 +154,6 @@ CONFIG_RCU_STALL_COMMON=y
 CONFIG_REGMAP=y
 CONFIG_REGMAP_MMIO=y
 CONFIG_RESET_CONTROLLER=y
-# CONFIG_RTC is not set
 # CONFIG_SCHED_INFO is not set
 # CONFIG_SCSI_DMA is not set
 CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
index a09c7c4b61a553c9f0e8f89e4b897d55abd86d6d..51265edf0ea0c4fd9101caf81f8d2ebf2f007054 100644 (file)
@@ -166,7 +166,6 @@ CONFIG_REGMAP_MMIO=y
 CONFIG_RESET_CONTROLLER=y
 CONFIG_RFS_ACCEL=y
 CONFIG_RPS=y
-# CONFIG_RTC is not set
 # CONFIG_SCHED_INFO is not set
 # CONFIG_SCSI_DMA is not set
 CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
index 997d332061acb439fb7e693267cb5644b5658591..6d03b00f54c17d0982cf389e94ebf66f9ded37ed 100644 (file)
@@ -215,8 +215,8 @@ CONFIG_ARCH_FLATMEM_ENABLE=y
 # CONFIG_ARM_CCI400_PMU is not set
 # CONFIG_ARM_CCI500_PMU is not set
 # CONFIG_ARM_CCN is not set
-CONFIG_ARM_CPU_TOPOLOGY=y
 # CONFIG_ARM_CPUIDLE is not set
+CONFIG_ARM_CPU_TOPOLOGY=y
 # CONFIG_ARM_CRYPTO is not set
 CONFIG_ARM_DMA_MEM_BUFFERABLE=y
 # CONFIG_ARM_ERRATA_326103 is not set
@@ -323,8 +323,6 @@ CONFIG_ATM_CLIP_NO_ICMP=y
 # CONFIG_B43 is not set
 # CONFIG_B43LEGACY is not set
 # CONFIG_B44 is not set
-# CONFIG_SWCONFIG_B53 is not set
-# CONFIG_SWCONFIG_B53_SPI_DRIVER is not set
 # CONFIG_BACKLIGHT_ADP8860 is not set
 # CONFIG_BACKLIGHT_ADP8870 is not set
 # CONFIG_BACKLIGHT_BD6107 is not set
@@ -1448,9 +1446,9 @@ CONFIG_HZ_100=y
 # CONFIG_I2C_MPC is not set
 # CONFIG_I2C_MUX is not set
 # CONFIG_I2C_MUX_GPIO is not set
-# CONFIG_I2C_MUX_PINCTRL is not set
 # CONFIG_I2C_MUX_PCA9541 is not set
 # CONFIG_I2C_MUX_PCA954x is not set
+# CONFIG_I2C_MUX_PINCTRL is not set
 # CONFIG_I2C_MUX_REG is not set
 # CONFIG_I2C_MV64XXX is not set
 # CONFIG_I2C_NFORCE2 is not set
@@ -2598,8 +2596,8 @@ CONFIG_NET_VENDOR_AGERE=y
 CONFIG_NET_VENDOR_ALTEON=y
 CONFIG_NET_VENDOR_AMD=y
 CONFIG_NET_VENDOR_ARC=y
-CONFIG_NET_VENDOR_AURORA=y
 CONFIG_NET_VENDOR_ATHEROS=y
+CONFIG_NET_VENDOR_AURORA=y
 CONFIG_NET_VENDOR_BROADCOM=y
 CONFIG_NET_VENDOR_BROCADE=y
 CONFIG_NET_VENDOR_CAVIUM=y
@@ -2971,7 +2969,7 @@ CONFIG_PINCONF=y
 CONFIG_PINCTRL_SINGLE=y
 CONFIG_PINMUX=y
 # CONFIG_PKCS7_MESSAGE_PARSER is not set
-# CONFIG_PKCS7_TEST_KEY it not set
+# CONFIG_PKCS7_TEST_KEY is not set
 # CONFIG_PL320_MBOX is not set
 # CONFIG_PLAT_SPEAR is not set
 # CONFIG_PLIP is not set
@@ -3183,6 +3181,7 @@ CONFIG_RFKILL=y
 # CONFIG_RPCSEC_GSS_KRB5 is not set
 # CONFIG_RPR0521 is not set
 # CONFIG_RT2X00 is not set
+# CONFIG_RTC is not set
 # CONFIG_RTC_CLASS is not set
 # CONFIG_RTC_DEBUG is not set
 # CONFIG_RTC_DRV_ABB5ZES3 is not set
@@ -3629,13 +3628,13 @@ CONFIG_SERIAL_EARLYCON=y
 # CONFIG_SFC is not set
 # CONFIG_SFI is not set
 # CONFIG_SGETMASK_SYSCALL is not set
-# CONFIG_SG_SPLIT is not set
 # CONFIG_SGI_IOC4 is not set
 # CONFIG_SGI_IP22 is not set
 # CONFIG_SGI_IP27 is not set
 # CONFIG_SGI_IP28 is not set
 # CONFIG_SGI_IP32 is not set
 # CONFIG_SGI_PARTITION is not set
+# CONFIG_SG_SPLIT is not set
 CONFIG_SHMEM=y
 # CONFIG_SH_ETH is not set
 # CONFIG_SH_TIMER_CMT is not set
@@ -3723,8 +3722,8 @@ CONFIG_SND_DRIVERS=y
 # CONFIG_SND_DYNAMIC_MINORS is not set
 # CONFIG_SND_ECHO3G is not set
 # CONFIG_SND_EMU10K1 is not set
-# CONFIG_SND_EMU10K1_SEQ is not set
 # CONFIG_SND_EMU10K1X is not set
+# CONFIG_SND_EMU10K1_SEQ is not set
 # CONFIG_SND_ENS1370 is not set
 # CONFIG_SND_ENS1371 is not set
 # CONFIG_SND_ES1688 is not set
@@ -4050,6 +4049,8 @@ CONFIG_STRIP_ASM_SYMS=y
 # CONFIG_SUSPEND_SKIP_SYNC is not set
 CONFIG_SWAP=y
 # CONFIG_SWCONFIG is not set
+# CONFIG_SWCONFIG_B53 is not set
+# CONFIG_SWCONFIG_B53_SPI_DRIVER is not set
 # CONFIG_SWCONFIG_LEDS is not set
 # CONFIG_SX9500 is not set
 # CONFIG_SXGBE_ETH is not set
@@ -4073,9 +4074,9 @@ CONFIG_SYSVIPC_SYSCTL=y
 # CONFIG_SYS_HYPERVISOR is not set
 # CONFIG_T5403 is not set
 # CONFIG_TARGET_CORE is not set
-# CONFIG_TASK_XACCT is not set
 # CONFIG_TASKSTATS is not set
 # CONFIG_TASKS_RCU is not set
+# CONFIG_TASK_XACCT is not set
 # CONFIG_TC35815 is not set
 # CONFIG_TCG_TPM is not set
 # CONFIG_TCIC is not set
@@ -4413,6 +4414,7 @@ CONFIG_USB_GADGET_VBUS_DRAW=2
 # CONFIG_USB_LCD is not set
 # CONFIG_USB_LD is not set
 # CONFIG_USB_LED is not set
+# CONFIG_USB_LEDS_TRIGGER_USBPORT is not set
 # CONFIG_USB_LED_TRIG is not set
 # CONFIG_USB_LEGOTOWER is not set
 # CONFIG_USB_LINK_LAYER_TEST is not set
@@ -4469,7 +4471,6 @@ CONFIG_USB_OHCI_LITTLE_ENDIAN=y
 # CONFIG_USB_OTG_BLACKLIST_HUB is not set
 # CONFIG_USB_OTG_FSM is not set
 # CONFIG_USB_OTG_WHITELIST is not set
-# CONFIG_USB_LEDS_TRIGGER_USBPORT is not set
 # CONFIG_USB_OXU210HP_HCD is not set
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_PHY is not set
@@ -4612,7 +4613,7 @@ CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
 # CONFIG_VGA_ARB is not set
 # CONFIG_VGA_SWITCHEROO is not set
 # CONFIG_VHOST_CROSS_ENDIAN_LEGACY is not set
-# CONFIG_VHOST_NET is not seta
+# CONFIG_VHOST_NET is not set
 # CONFIG_VIA_RHINE is not set
 # CONFIG_VIA_VELOCITY is not set
 # CONFIG_VIDEO_ADV7170 is not set