x86: image: cleanup before creating image
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Tue, 14 Jan 2020 17:45:43 +0000 (18:45 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sun, 1 Mar 2020 20:36:00 +0000 (21:36 +0100)
There can be some leftovers from other image recipes, if the same
directory names are used and multiply image types are selected.
Therefore remove directories used in the recipe, before contents for the
image are prepared.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/x86/image/Makefile

index eb0db417a32aa28192ed9840903b2342a63149fc..2838b3139c139305554242e260cada3205af2482 100644 (file)
@@ -60,6 +60,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
 
   define Image/Build/grub2
        # left here because the image builder doesnt need these
+       rm -fR $(KDIR)/root.grub $(KDIR)/grub2
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
@@ -93,6 +94,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
 endif
 
 define Image/Build/iso
+       rm -fR $(KDIR)/root.grub $(KDIR)/grub2
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \