mvebu: image: don't create unnecessarily shell variables
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Sat, 11 May 2019 17:37:32 +0000 (19:37 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 11 May 2019 21:11:04 +0000 (23:11 +0200)
Use make syntax to pass the U-Boot image location and boot with root
partitions size, instead of relying on shell functions and variables.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/mvebu/image/Makefile
target/linux/mvebu/image/gen_mvebu_sdcard_img.sh

index 108b569c0773f4689784bf84855d44b2ccb21c01..9084b3e02818f79bbc3f1b3bf0a51ae600bf29c7 100644 (file)
@@ -42,25 +42,19 @@ define Build/boot-img-ext4
 endef
 
 define Build/sdcard-img
-       if [ -n "$(UBOOT)" ]; then UBOOT="$(STAGING_DIR_IMAGE)/$(UBOOT)"; fi; \
-       BOOTFS_SIZE=$$(( $(CONFIG_TARGET_KERNEL_PARTSIZE) * 1024 * 2 )); \
-       ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        SIGNATURE="$(SIGNATURE)" \
        ./gen_mvebu_sdcard_img.sh $@ \
-               $$UBOOT \
-               c $$BOOTFS_SIZE $@.boot \
-               83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+               $(if $(UBOOT),$(STAGING_DIR_IMAGE)/$(UBOOT)) \
+               c $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
+               83 $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS)
 endef
 
 define Build/sdcard-img-ext4
-       if [ -n "$(UBOOT)" ]; then UBOOT="$(STAGING_DIR_IMAGE)/$(UBOOT)"; fi; \
-       BOOTFS_SIZE=$$(( $(CONFIG_TARGET_KERNEL_PARTSIZE) * 1024 * 2 )); \
-       ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        SIGNATURE="$(SIGNATURE)" \
        ./gen_mvebu_sdcard_img.sh $@ \
-               $$UBOOT \
-               83 $$BOOTFS_SIZE $@.bootimg \
-               83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+               $(if $(UBOOT),$(STAGING_DIR_IMAGE)/$(UBOOT)) \
+               83 $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.bootimg \
+               83 $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS)
 endef
 
 define Build/omnia-medkit-initramfs
index 67416ed80cfaa6c04d6a33bb85f8125b30a9e6ce..e0230e48b64b7ba7c5cceb42d5275d4c965787e8 100755 (executable)
@@ -18,7 +18,7 @@
 #
 
 usage() {
-       echo "$0 <outfile> [<bootloader> <type_partitionN> <sectors_partitionN> <img_partitionN>]?"
+       echo "$0 <outfile> [<bootloader> <type_partitionN> <size_partitionN> <img_partitionN>]?"
 }
 
 # always require first 2 or 3 arguments
@@ -46,7 +46,7 @@ dd if=/dev/zero of="$OUTFILE" bs=512 count=1 >/dev/null
 printf "Done\n"
 
 while [ "$#" -ge 3 ]; do
-       ptgen_args="$ptgen_args -t $1 -p $(($2 / 2 + 256))"
+       ptgen_args="$ptgen_args -t $1 -p $(($2 * 1024 + 256))"
        parts="$parts$3 "
        shift; shift; shift
 done